Nexus 5 Bluetooth Problems - Car Audio

radus

macrumors 6502
Original poster
Jan 12, 2009
491
303
hello I have massive problems pairing my Nexus 5 to the BMW Bluetooth module - it pretends to pair but stays in "Please Wait"

Is there anybody here without "bluetooth problems"?

had to switch back to the iphone 5s because of this ! (iphone 4 , iphone 5, xperia zl, iphone 5s are pairing remarkable good...)
 

mattopotamus

macrumors G5
Jun 12, 2012
13,634
4,038
hello I have massive problems pairing my Nexus 5 to the BMW Bluetooth module - it pretends to pair but stays in "Please Wait"

Is there anybody here without "bluetooth problems"?

had to switch back to the iphone 5s because of this ! (iphone 4 , iphone 5, xperia zl, iphone 5s are pairing remarkable good...)
Mine works fine. Are you pairing when you first start your car? I know a lot of cars will only pair within the first few seconds and if no device is connected it will auto shut off.
 

Lloydbm41

Suspended
Oct 17, 2013
4,019
1,455
Central California
hello I have massive problems pairing my Nexus 5 to the BMW Bluetooth module - it pretends to pair but stays in "Please Wait"

Is there anybody here without "bluetooth problems"?

had to switch back to the iphone 5s because of this ! (iphone 4 , iphone 5, xperia zl, iphone 5s are pairing remarkable good...)
No problems pairing my Nexus 5 with Ford Focus, Chevy Volt, wireless headsets, wireless BT speakers or anything else. Works perfectly with everything.

Are you stock or using a ROM? Have you made any changes to the phone at all?
 

radus

macrumors 6502
Original poster
Jan 12, 2009
491
303
stock android, pairing procedure as BMW wants it

thanks for your help!

I use stock android (now 4.4.2) - there are no problems using a bt-headset, but pairing with the cars bluetooth just does not work (beginning from the cold), the cars bluetooth works flawlessy with iPhones and Sony xperia zl (Android 4.2.2)
 

Lloydbm41

Suspended
Oct 17, 2013
4,019
1,455
Central California
thanks for your help!

I use stock android (now 4.4.2) - there are no problems using a bt-headset, but pairing with the cars bluetooth just does not work (beginning from the cold), the cars bluetooth works flawlessy with iPhones and Sony xperia zl (Android 4.2.2)
Sounds like an a2dp issue. Clear all of your BT connections from your nexus 5. Reboot nexus 5. Start your car and go into phone pairing mode. Start BT on your nexus and then click search for devices. You should now see your car and the car should reset its display to match pin numbers with your phone.
 

mattopotamus

macrumors G5
Jun 12, 2012
13,634
4,038
I did have an issue that started this Monday out of nowhere. Every time my phone would pair it would auto launch google music (I have audio off under the paired settings). The only way I was able to fix it was to disable google play music totally.
 

radus

macrumors 6502
Original poster
Jan 12, 2009
491
303
--> Lloydbm41

that is what I did - I even deleted all the car’s connectiones, rebooted the nexus 5, enabled ART (as the last trial) … did not work, the phone is able to find the car and I can enter the car’s bt-passkey … and then “Plaese wait” … for ever
 

Delorean2006

macrumors 6502a
Feb 4, 2012
775
233
No problems pairing my Nexus 5 with Ford Focus, Chevy Volt, wireless headsets, wireless BT speakers or anything else. Works perfectly with everything.

Are you stock or using a ROM? Have you made any changes to the phone at all?
You have a Chevy volt? I love that car! My favorite electric car, I despise pretty much any electric car other then that, how do you like it and I only came here because I'm getting a nexus 5 and I strictly use Bluetooth when I'm in my car
 

Lloydbm41

Suspended
Oct 17, 2013
4,019
1,455
Central California
You have a Chevy volt? I love that car! My favorite electric car, I despise pretty much any electric car other then that, how do you like it and I only came here because I'm getting a nexus 5 and I strictly use Bluetooth when I'm in my car
Chevy Volt is probably my favorite car I have ever owned in my nearly 3 decades of driving. Not because it is the most luxurious or the fastest or the best looking, but all around it is just a fun a little car. And the fact that I go on average 1200 miles before needing gas... and it only costs $33 here in California to fill up (on Premium!) Electric cost is roughly $35 a month on your home electric bill. In California, you can get special rates for home electric if you own the Volt. And the $7500 I got back on my tax return from the Federal government was quite nice!

Anyway, I have no issues connecting my Nexus 5 or previously my Nexus 4 or Nexus 7 to my Volt. It connects right up every time. Doesn't matter if I use a custom ROM or stock Android. Additionally, you can use your steering wheel controls to change tracks on Pandora, G Music and a couple other music players I have used. Calls are crystal clear and also controlled by the steering wheel controls.
 

Vegastouch

macrumors 603
Jul 12, 2008
5,466
389
Las Vegas, NV
No issue. My Nexus 5 works better with my car (13 Nissan Altima) than my GS3 did. And you dont have to start the car to pair it. Just turn on to accesssaries so the bluetooth is on. There is no difference from that and starting it.
 
Last edited:

AutoUnion39

macrumors 601
Jun 21, 2010
4,890
941
--> Lloydbm41

that is what I did - I even deleted all the car’s connectiones, rebooted the nexus 5, enabled ART (as the last trial) … did not work, the phone is able to find the car and I can enter the car’s bt-passkey … and then “Plaese wait” … for ever
Do you have iDrive? What I usually do is delete the devices from both the car and phone. Then reboot phone. Then when you are search for devices, make sure to punch in the same pass-key for both (usually do 1111 or 0000).

My 4.4 ROM (on my GS4) works perfectly with my BMW and Audi.
 

radus

macrumors 6502
Original poster
Jan 12, 2009
491
303
its a 2005 e53 x5 without iDrive - may be i should by a new car, but it is nearly as good as a new one and i am the first owner.
so i bought an iPhone 5s and use it all the day.

in the evening i play half an hour with my Nexus 5 - I love it so - it is such a shame that i can not get it to work with the car's bluetooth
 

Rampant Lion

macrumors newbie
Dec 31, 2013
2
0
Same issue

I have a 2004 BMW X5 e53 without Nav, never had a problem pairing any phone but now Nexus 5 pairs ok with the car then drops the bluetooth connection 10 seconds later... All I want to do it use the car kit.
 

Vegastouch

macrumors 603
Jul 12, 2008
5,466
389
Las Vegas, NV
I have issues with my car not seeing all my contacts on the Nexus 5. :(
Has to be your car. My Nexus 5 works better with my car than my GS3 did in that respect. Could be thebphone i guess. I dont really kow why my car wouldnt remember my contacts w/ the GS3 but does w/ my Nexus.
 

radus

macrumors 6502
Original poster
Jan 12, 2009
491
303
it was the car

the nexus 5 works perfectly with a friends Porsche PCM 3.1 ...
 

pojo1806

macrumors 68020
Feb 6, 2013
2,335
1,228
United Kingdom
Has to be your car. My Nexus 5 works better with my car than my GS3 did in that respect. Could be thebphone i guess. I dont really kow why my car wouldnt remember my contacts w/ the GS3 but does w/ my Nexus.
I thought that but it worked perfectly with iPhone 4 and 5S. :(
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.