NFS / Solaris not working right

Discussion in 'macOS' started by tzurita, Nov 9, 2006.

  1. tzurita macrumors newbie

    Oct 27, 2006
    Macbook Pro:

    Tried two ways:
    1. using NFSManager
    2. modifying Netinfo database from the command line

    I can create the NFS share but for whatever reason I can't install certain packages on the solaris box. My idea was to get an external firewire drive and put all the software I would ever need on it (Oracle, SMC, N1, etc) and then go to client sites and have the install kicked off via NFS on the share I created.

    I can mount it just fine, start the installation but some packages install and some don't. I am using Solaris 10, for the most part, and do not know what else to do.

    BTW, I have shared this with root being anonymous and with nobody being anonymous.
  2. rhoydotp macrumors 6502


    Sep 28, 2006
    Have you tried to copy the install files local to the Solaris and try to install from there? If this works, then most probably, the application is trying to write something on the shared drive which I assume is not mounted with rw permissions.

    Btw, what do you mean by this?
  3. tzurita thread starter macrumors newbie

    Oct 27, 2006
    Ok, I have figured out what the problem was. I went through various iterations of testing and the solution was actually quite simple. Here is my troubleshooting methodology:

    1. Copied package to local file system on Solaris host and install - WORKED
    - let me know that the package itself was fine
    2. Read about NFSv4 (Solaris 10's Default) and mod'd file /etc/default/nfs to allow a max of NFSv3 on client calls - DID NOT WORK
    - did not rule this out, I was thinking that it may be v4 + (something else)
    3. Read Chris Marget's info about making Mac OS X a Solaris Jumpstart server - link - - informative and led to my solution - WORKED AND FIXED AFTER DOING:

    Chris Marget:
    2.) Prepare The Jumpstart Filesystem

    The gotcha with the Solaris jumpstart tree is that it cannot be installed on an HFS filesystem. Unless you've rebuilt your Mac using UFS, you've probably got an HFS filesystem. Not sure which you've got? Try this in the filesystem where you'd like your jumpstart files to live:

    $ touch foo
    $ touch FOO
    $ ls | grep -i foo

    I was now sure that all I had to do was create a UFS filesystem, place my software there and make it an NFS share.

    The following command creates a 24G UFS Volume (I created it on a Firewire attached drive) and then attaches the image to /Volumes/Downloads.

    hdiutil create -size 24g /Volumes/MyExtraHD/Downloads/downloads.dmg -type UDIF -fs UFS -volname "Downloads" -attach

    I then shared /Volume/Downloads via nfs with the following options:

    NFS options: ro, maproots:root

    Install works now.

Share This Page