Nike APP appears from nowhere!!

Discussion in 'Jailbreaks and iOS Hacks' started by iViet, Aug 10, 2010.

  1. iViet macrumors member

    Joined:
    Oct 26, 2007
    #1
    so this "nike + ipod" app appears after i JB and install winterboard. i've never downloaded it, and when i click on it, it just crashes. so i re-spring the phone and it dissapears..........but shows up on my sbsettings/hide icons, as "on" (don't hide). anybody wanna tell me how to remove this?
     
  2. Benji222 macrumors 65816

    Benji222

    Joined:
    Dec 21, 2009
    Location:
    So Cal
    #2
    Its always been inside your phone in your settings. Just leave it so its hidden and dont worry about it :D
     
  3. Bandolier macrumors 6502a

    Joined:
    Aug 2, 2010
  4. iViet thread starter macrumors member

    Joined:
    Oct 26, 2007
    #4
    lol ......i've never installed installous, but i did install Rock.....but i removed it already....hmmm i'm gonna ssh and see if i can find and remove this ;)
     
  5. iViet thread starter macrumors member

    Joined:
    Oct 26, 2007
    #5
    funny thing is, there's no such app, cause i tried a search for it lol
     
  6. Frenchjay macrumors 68000

    Frenchjay

    Joined:
    Jul 6, 2010
    #6
    This happened to me when i downloaded from the apple app store.

    It brought up some blank white apps and then all the apps i had hidden using sbsettings.
     
  7. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #7
    Yes, there is. It is a native app, like Stocks, so it won't show up in the App Store. The issue you are having is that Nike + iPod is usually hidden; it usually only shows up in Settings > Nike + iPod. You have installed an app (probably SBSettings) that relies on a tool called libhide. LibHide is used by applications that wish to hide their icons (such as SBSettings) or which can hide icons for other apps (such as Categories and Poof). There is a bug in recent versions of libhide which causes hidden apps to appear on the desktop when new apps are installed from the App Store on the phone.

    There is a simple solution to this: simply respring your phone, and the app icons will be re-hidden.
     
  8. Benji222 macrumors 65816

    Benji222

    Joined:
    Dec 21, 2009
    Location:
    So Cal
    #8
    It has always been there.
    Nike teamed up with Apple for some shoe stuff ro soemthing before:
    [​IMG] [​IMG]
     
  9. iViet thread starter macrumors member

    Joined:
    Oct 26, 2007
    #9
    thanks for the info, i almost deleted the nike folder i found through SSH, that might of caused some problems :) oops, look like i deleted half of it haha
     
  10. iViet thread starter macrumors member

    Joined:
    Oct 26, 2007
    #10
    ok, so i permanently deleted nike & stocks, it disappeared completely off the "hide icons"......will i have any problems? sbsettings still working ; )
     
  11. Benji222 macrumors 65816

    Benji222

    Joined:
    Dec 21, 2009
    Location:
    So Cal
    #11
    I wouldnt have suggested it but whatever floats your boat.
     
  12. iViet thread starter macrumors member

    Joined:
    Oct 26, 2007
    #12
    if i can free up some memory on unwanted apps, i figure why not!
     
  13. ezdude macrumors newbie

    Joined:
    Jul 18, 2009
    #13
    What I did to apparently solve the problem.

    In snowboard I unselected the hide icon option since I had turned it on.
    This makes it so that it doesn't hide the icon, which probably taps into the libhide settings in order for it to work.

    Note: I had gotten rid of springboard while trying to solve the problem. I had to reinstall it just to find out that that particular hide setting was automatically on. So the settings were still saved somewhere even though I had uninstalled it.

    With that in mind I proceeded to uninstall winterboard again.

    Then went back to cydia and uninstalled, from the package section under manage, the preferenceloader by bigboss. I figured it was this what allowed it to remember the setting I mentioned before.

    Doing this will not let you play with around with themes and stuff like that, but it's a way to really get rid of the icons for sure. At least that's what I think for now.

    I never actually tried to simply turn off 'hide winterboard icon' and then go from there, I really just wanted to get rid of them, maybe I'll try later.

    Last: you can just forget about them build a folder just for them and put it somewhere it won't bother you, I'm running iOS 4.0.
     
  14. silroc macrumors 6502

    silroc

    Joined:
    Jun 17, 2010
    #14
    Same exact thing happened to me but it all worked itself out - can't remember what I did
     
  15. iPhone4Hakz macrumors newbie

    Joined:
    Jun 15, 2011
    #15
    easiest way to get rid of this app is to follow instructions below:

    Need to be installed:

    SBSettings
    iFile

    (has to be JB of course)

    Open SBSettings -> App Folders

    Select Nike.app

    It will show you the location of the nike+ipod app which is /Applications/Nike.app

    Open iFile

    Navigate to the root dir (/)
    select 'Applications' (should be at top) [your location in the status bar will be /var/stash/Applications.pwn]

    Scroll down to nike.app, click the 'edit' button in top right hand corner and the selection bubble will show up next to the 'names.app' select nike.app and click the delete button that shows up next to it.

    This is only to completely delete apps you dont want or never use.

    ( i personally have a backup of my original phone firmware + contacts saved to a externalHD just in case i ever want to go back to normal or mess up some serious files XD )
     

Share This Page