nMP - Problems with USB hubs, can anyone recommend one known to work?

Discussion in 'Mac Pro' started by OCDMacGeek, Oct 4, 2015.

  1. OCDMacGeek macrumors 6502a

    OCDMacGeek

    Joined:
    Jul 19, 2007
    #1
    Hello,

    I have a nMP - Mac Pro (Late 2013). Long story short -- I was hoping for a recommendation from a nMP owner who has a USB 3.0 hub that has worked for them (and continues to work fine under El Capitan).

    The long story: I've been having frequent spinning beach calls for a few months now, ever since 10.10.4, and I have been troubleshooting all sorts of issues -- third party software, kexts, etc. I cleaned out my system like crazy. I could never seem to narrow down what was causing the problems.

    Today, I deleted some unused kexts that I thought might be causing problems, and restarted. However, I got a black screen with no boot. I thought I must have screwed up my system by deleting the wrong kexts, even though I was very careful (only deleted kexts confirmed to be third party and have been created by apps I no longer use). I could not even get to reseting PRAM, just would not boot at all. In the end, I realized that my system would only boot if I unplugged my two USB 3.0 hubs.

    There are the two hubs I have:

    http://www.amazon.com/dp/B00DVHP478

    http://www.amazon.com/dp/B00H7INZBE

    Even with absolutely no devices attached to the either hub, the system still would not boot unless they were disconnected entirely. Even after PRAM and SMC resets, still won't boot unless both hubs are disconnected. In research, I see that this sometimes happens -- it seems that different hubs work or don't work with different Mac Pros.

    Upon unplugging these two hubs, my system is running more smoothly than it has in months. No spinning beach balls since. This is odd because the Mac always booted fine with the hubs, although I had frequent complete system freezes. I'm not sure what finally caused them to stop working on boot altogether, but I am almost glad they did because now I have gotten much closer to isolating the problem that has been plaguing me.

    I'll be continuing my testing to see if it is a USB device as opposed to hub that is causing my problems, but it doesn't appear so.

    So, I am hoping for a recommendation from a nMP (Late 2013) owner who has a USB 3.0 hub that has worked for them.

    Thanks!
     
  2. Redneck1089 macrumors 65816

    Redneck1089

    Joined:
    Jan 18, 2004
    #2
  3. OCDMacGeek thread starter macrumors 6502a

    OCDMacGeek

    Joined:
    Jul 19, 2007
    #3
  4. DaReaLDeviL macrumors newbie

    DaReaLDeviL

    Joined:
    Apr 15, 2015
    Location:
    Germany
    #4

Share This Page