No 3G after Update to 5.0.1

engelke2010

macrumors 65816
Original poster
Mar 28, 2010
1,015
83
I updated my iOS from 4.3.3 to 5.0.1 last night. I noticed this morning (too late to fix now) that I cannot see anything in Settings/General to enable 3G. I don't have access to WiFi at work. I tried Network reset and nothing. Is there anything else I can do bar waiting until late this afternoon and restore to get my 3G back? I would rather not be stuck on Edge while at work. 3G at work is slow enough.
 

RodThePlod

macrumors 6502a
Sep 7, 2005
704
172
London
Is there anything else I can do bar waiting until late this afternoon and restore to get my 3G back? I would rather not be stuck on Edge while at work. 3G at work is slow enough.
  • Is the phone picking up your carrier OK?
  • When you go into Settings, General, Network, what options do you have?
  • Silly question, but have you tried shutting the phone down completely and then restarting?
RTP.
 

engelke2010

macrumors 65816
Original poster
Mar 28, 2010
1,015
83
  • Is the phone picking up your carrier OK?
  • When you go into Settings, General, Network, what options do you have?
  • Silly question, but have you tried shutting the phone down completely and then restarting?
RTP.
My iPhone 4 is working fine. On my iPad 2, under Settings/General/Network, it shows just VPN and WiFi. On Cellular Data, it shows Cellular Data, but not Enable 3G
 

engelke2010

macrumors 65816
Original poster
Mar 28, 2010
1,015
83
I ended up restoring my iPad 2 and it looks like 3G is back (I'm still syncing everything back). However, I have another question which may be a dumb one. With iOS 5 or 5.0.1, was Cellular Data and Enable 3G combined on iPad2? I don't see that with my iPhone 4, but see it on my iPad.