No access to library!!!

Discussion in 'macOS' started by LinusR, Feb 4, 2011.

  1. LinusR macrumors regular

    LinusR

    Joined:
    Jan 3, 2011
    #1
    Hi friends, I have a big problem.

    No application has access to my library folder. That's not good because I have no access to my keychain. Safari has no access to the keychain. I can't save bookmarks anymore because they are saved inProperty Lists which are in the Library.

    I need help. If anyone has an idea, please post.

    Linus :(
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
  3. LinusR thread starter macrumors regular

    LinusR

    Joined:
    Jan 3, 2011
    #3
  4. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #4
    You can't set permissions via Finder?
     
  5. LinusR thread starter macrumors regular

    LinusR

    Joined:
    Jan 3, 2011
    #5
    I can. How do I have to change the permissions? I have to change every file, right?
     
  6. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #6
    Follow the second link I gave in my first post for instructions.
     
  7. LinusR thread starter macrumors regular

    LinusR

    Joined:
    Jan 3, 2011
    #7
    that does not work. I can't set the permissions for any subfolder, the menu item is not enabled. Is there no way to reset the permissions?
     
  8. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #8
    Have you clicked on the lock icon in the bottom right and entered your password and then selected the right user and write and read access and the selected "Apply to enclosed items"?
     
  9. LinusR thread starter macrumors regular

    LinusR

    Joined:
    Jan 3, 2011
    #9
    No, I didn't... Now everything works again. I switched the permissions to "Everyone" = "Read and Write". I think that are no perfect settings, right?
    But it works. If you know better settings, tell.

    thanks for your help, without you I have had a big problem.

    Hav a nice day,

    Linus
     
  10. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #10
    Try the user you use. If it is not in the list, click the + button and add it. Using the "everyone" setting will give everyone access, even without password, something you don't really want.

     

Share This Page