No Admin User on Snow Leopard!

Discussion in 'Mac Basics and Help' started by Brainstrainer, Jun 4, 2010.

  1. Brainstrainer macrumors newbie

    Joined:
    Jun 4, 2010
    #1
    I bought a recent 2nd hand MacBook Pro running Snow Leopard, and using Migration Assistant imported my user from my iBook G4 running Tiger. I just wanted to import my documents, (600MB) but it brought over 3.5Gb of I'm not sure what.

    Then I got rid of Admin privileges of the MacBook Pro User as System Preferences showed my iBook user as having Admin privileges on the MBP. Then I logged into the MBP as my iBook user, my username and password were recognised for login purposes, but not for changing settings i.e. when I click the padlock to change settings.

    Now when I login as iBook username on the MBP it tells me that the home folder for iBook username isn't located in the usual place or can't be accessed. And when I look at Accounts in Sys Prefs it shows me as actually logged in as a Guest - no Admin.

    Basically what I need to know is when moving all my data to a new computer should I import the user from the old computer, or import the data to the username of the new computer?

    And how should I proceed from the present somewhat sticky situation I am in? I reckon getting an Admin user on the MBP must be a bit of a priority!

    Any advice gratefully received!
     
  2. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #2
    You probably need to enable root, also known as the super-user.

    Since you've locked yourself out from admin access, you'll need to boot to the 10.6 disc to enable root. From Utilities, choose Reset Password, and when selecting the account to reset password for, choose System Administrator (root). Enter in the password and verify it. Save the password, and then exit the installer and restart. At the login window, or if you have it set to auto-login, log out to return to the login window, choose Other... and enter root (all lowercase) as the name, and then the password that you set. In root you will have full access to the system, including granting admin rights to the accounts which are standard at the moment. You also will see some additional folders in Macintosh HD you couldn't see before. Do not touch these in any way or you could hurt the OS. Access System Preferences->Accounts, click one of the non-admin accounts and click the checkmark next to "Allow user to administer this computer" and then log out and into the one you just gave admin access to again.

    To disable root, go into Accounts preferences on an admin account, click Login Options at the bottom of the list of accounts, and to the right, click the Join button next to the words Network Account Server..., click Open Directory Utility, click the lock to make changes, and under the Edit menu, choose Disable Root user.

    Consult this Apple support article if you get lost in my wall of text.
     
  3. padawer macrumors newbie

    Joined:
    Aug 10, 2010
    #3
    solution

    Sorry for the repost. This problem can cause someone to erroneously believe they've lost data, reformat, etc. I'm hopeful this prevents someone from experiencing that outcome, although I apologize for the redundancy.

    I had the same problem, and a VERY QUICK AND EASY solution created by Thomas Tempelmann elsewhere worked for me. (In my case, I also saw the dialog box that said, "The home folder for user "xxxxxxx" isn't located in the usual place or can't be accessed." As an aside, I suspect the problem may have arisen when two hard disks shared the same name "Macintosh HD" although I'm not entirely sure of that being the cause.)

    SOLUTION that worked for me:
    1) Open the Terminal.app
    2) Type this and then press return:
    sudo xattr -d com.apple.FinderInfo /
    (note: don't leave off the last space and "/" character before pressing return)
    3) It should have asked for your password. Type it and press return.
    4) Now do nothing else, except quit Terminal.app and then RESTART your computer (select "Restart" from the Apple menu)

    More about the original problem Thomas described (identical to mine): "Finder shows empty desktop, and even an 'open /Applications' in Terminal does not open a window. Furthermore, 'open /' leads to the message that 'The alias <diskname> can't be opened because the original item can't be found'."

    I had almost given up hope, but this simple command that resulted in a repaired "com.apple.FinderInfo" file did the trick for me. I hope this works for you.
     
  4. Brainstrainer thread starter macrumors newbie

    Joined:
    Jun 4, 2010
    #4
    JediMaster wields sabre of wisdom

    Thanks JM - your solution worked a treat.
     

Share This Page