No airport card installed. Fried logic board?

Discussion in 'MacBook Pro' started by Lestat1, Nov 19, 2010.

  1. Lestat1 macrumors newbie

    Joined:
    Nov 19, 2010
    Location:
    Singapore
    #1
    Okay, issue at hand is:
    Completely no detection of Airport card. And I'm wondering if its due to a fried motherboard or conked cable. I flew in a new airport chip albeit a different model than the one pre-installed. Its past warranty and I don't have the extended warranty so I'm pretty fine with ripping and changing stuff, but not fine paying the service centre for something I believe I can solve on my own.

    Solutions attempted:
    1. Reset PRAM
    2. Reset SMC
    3. Reset SMC and PRAM
    4. Replaced airport chip
    5. Installed new chip and installed OsX 10.6
    6. Used old chip and installed OsX 10.6
    7. Did an extended diagnistics with no errors.

    Cause:
    Probably because I walked into a wall, with my MBP taking a side blow, don't ask why I walked into a wall because I don't know either.

    Another sideline question:
    If I had to change the logic board, can I use one with a faster processor? I got the 2.66 model.

    Thanks for pondering on my predicament if you got this far.
     
  2. fehhkk macrumors 6502a

    fehhkk

    Joined:
    Jun 11, 2009
    Location:
    Chicago, IL
    #2
    Have you tried going to System Preferences, on the left pane, click the + button, see if you can add the airport device there.
     
  3. Lestat1, Nov 20, 2010
    Last edited: Nov 20, 2010

    Lestat1 thread starter macrumors newbie

    Joined:
    Nov 19, 2010
    Location:
    Singapore
    #3
    The Airport device isn't detected so I can't do that add..

    Now trying to use Pacifist to put in appleairport.kext and appleairport2.kext.

    Edit: Still no go.
     

Share This Page