No Airport Card Installed?

Discussion in 'MacBook Pro' started by irishelysia923, Apr 20, 2013.

  1. irishelysia923 macrumors newbie

    Joined:
    Apr 20, 2013
    #1
    HELP! OK so I have a macbook Pro 15" unibody running OSX 10.6.8 Snow Leopard I guess it is.

    This morning I opened the case (after leaving it in sleep mode for a couple days in my bag, oops) and things were acting screwing. So i restarted, installing an update while i was at it. Upon reboot the airport said that "No Airport card installed" So I rebooted screwed around restarted reset the PRAM thing etc etc. My boyfriend was then able to fix it by deleting the airport out of the network prefences, rebooting & then re-adding the aiport and fixed it. Ta-da. Set the computer down & closed the lid and then left it for a bit and came back to use it and then the stupid thing still said no airport card installed. Gah. So I tried to use the same procedure he used to re-add the airport card, but now it isn't even listed in there to add. So I've been trying various ideas to try to solve this including doing the PRAM thing like a million times, taking out the battery, letting it hang out for awhile, rebooting, ive even tried massagint the black bar that leads to the display because I heard that the airport cable runs up thru there and sometimes gets loose. no luck. I tried deleting some files under library/preferences as suggested on another forum, rebooting, rebooting, etc. My BF could probably re-install a new airport card if I had to, but I want to make 100% sure this is a hardware problem and NOT a software one before I go that route OR drive the 300 miles to an Applestore and pay them (I got this computer in probably 2008ish so its long since out of warranty.)

    Soooo, does anyone else have any other suggestions? It seems like this is a really common problem. I dont have a problem replacing parts if need be but driving it up to an Applestore and paying them to troubleshoot and being without computer till I can go back up and get it....would be a hassle and probably end up costing half the cost of a new MBP at this point. This is really the only problem I've ever had with my mac.

    Thank you, in advance to anyones suggestions or ideas. I used to post here but lost my old username and had to start a new one :p Thanks again.
     
  2. makaveli559m macrumors 6502

    Joined:
    Apr 30, 2012
    #2
    Wow that is an odd problem, I haven't heard of this issue before. Have you tried to reinstall Mac OS?
     

Share This Page