No alert sound for Messages

DomC

macrumors 6502
Original poster
Jul 28, 2010
404
128
I just set up a new Mini and for some reason I can't get the alert sound for Messages to work. If I go to the Message prefs and choose a sound, I hear it. But if a new message comes in, I get a visual alert but no sound.
I've checked system notifications and anywhere I could think where sound is an option, and even reset PRAM. Still nothing. No issue with Mail alert sounds, just Messages.
I figure this is a Mojave issue and not the Mini, but who knows.
Any ideas?
 

niji

Contributor
Feb 9, 2003
1,854
1,982
hokkaido
Hi
A possibility is:
Are you using yr iPhone at the same time time and in close proximity to yr Mac?
If so, it won't make a sound on yr Mac since it understands you are working on yr iPhone.
 

DomC

macrumors 6502
Original poster
Jul 28, 2010
404
128
Phone isn't an issue. I hear nothing whether it's right beside the Mini or in the other room. Plus with my previous machine and OS alerts would makes sounds on both at the same time.
 

DomC

macrumors 6502
Original poster
Jul 28, 2010
404
128
Finally found the issue. Audible notifications for Messages and Reminders now require the "Play user interface sound effects" checked in the System prefs. I never have checked this in other OS versions since the sounds are kind of hokey and the apps didn't require it.
So now I can hear when I get new Messages, but also get the goofy sound when I empty the trash.
Oh goodie.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.