No Application will Launch

Discussion in 'macOS' started by Dev2, Feb 8, 2011.

  1. Dev2 macrumors newbie

    Joined:
    Dec 5, 2008
    #1
    Hello,

    I've Snow Leopard on my black MacBook. It's worked fine for years.

    I got an iPad today because I'm developing some apps for my college work. Turns out I had to update iTunes. I figured I might as well update everything, Safari, Java, OS X Update 3 et cetera.

    The first time it attempted to restart, Software update blocked the restart.:confused: Odd since that was the application to request it.

    Anyway I manually quit all the open programs and click Install and Restart. Nothing. I click restart and then it begins installing the updates. After a while it encounters an error. Nothing was changed and OS X boots as normal again. I run the software update program again everything seems to go ok.

    Finally it boots back in to OS X and the only app that seems to work is Terminal. I launch anything else and I get an error "X cannot open because of problem". It's kind of important I get this fixed because I have my college thesis on the machine which is not backed up. Finder seems to work but between that and Terminal everything refuses to open.

    Has anyone ever encountered this before? Any suggestions.

    -Dev
     
  2. Beaverman3001, Feb 8, 2011
    Last edited: Feb 8, 2011

    Beaverman3001 macrumors 6502

    Joined:
    May 20, 2010
    #2
    Open up terminal, type in "diskutil list" and find the volume OSX is installed on. On the right hand column of that list it will give a drive identifier (something such as disk0s2). Next type in "diskutil repairpermissions discidentifier". A failed update could have messed up the permissions on your applications.
     

Share This Page