no audio booted in Windows 7 (boot camp)

ibkelinski

macrumors newbie
Original poster
Jun 8, 2012
2
0
AZ
Just installed Windows 7 on my intel based imac 21.5" for college courses. I have no external audio on the Windows side. However, headphones work. The red (optical) light IS on when booted in Windows. It IS NOT lit booted in os X. Headphones DON'T work on the mac side and do work on the Windows side. External audio DOES work on the mac side. Any advice? Thanks!
 

BlazednSleepy

macrumors 6502a
Apr 15, 2012
692
181
Just installed Windows 7 on my intel based imac 21.5" for college courses. I have no external audio on the Windows side. However, headphones work. The red (optical) light IS on when booted in Windows. It IS NOT lit booted in os X. Headphones DON'T work on the mac side and do work on the Windows side. External audio DOES work on the mac side. Any advice? Thanks!
Did you install all of the drivers?
 
Comment

btbrossard

macrumors 6502a
Oct 25, 2008
973
11
Chicagoland
So if you plug headphones in under Windows, they work, but if you plug external speakers in they don't work? Or is it that the internal speakers don't work?

Are all the devices shown as working under Windows Device manager?
 
Comment

ibkelinski

macrumors newbie
Original poster
Jun 8, 2012
2
0
AZ
Device manager says drivers for that device are up to date. However, DriverBoost says one is out of date. Trouble shooting points to the device operating fine.

Windows - headphones work - built in speakers do not - red optical light is on in jack
OS X - headphones don't work - built in speakers do work - no red light from jack

Thanks for any and all input.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.