No Audio Connecting Macbook Pro to HDTV.

Discussion in 'MacBook Pro' started by blairh, May 30, 2010.

  1. blairh macrumors 68030

    blairh

    Joined:
    Dec 11, 2007
    #1
    Hey everybody.

    So I just picked up a new HDTV last week (2010 Samsung LCD model). I attempted to connect the TV and MBP. I had no issue getting video to come up on my TV but audio is not working.

    I had my MBP and TV connected via two cords from Monoprice (Mini DisplayPort Male to HDMI Male 32AWG Cable "5995" which handles video and 3.5mm Stereo Plug/2 RCA Plug Cable "665" which does audio). I'm connecting to a mid 2009 model MBP. I'm aware of the Mini Displayport Male and USB Male Audio to HDMI Female Converting Adapter "5969" however that still required me to purchase a separate HDMI cable to connect to that cord itself plus was four times the total price vs. using 5995 + 665 (plus the Monoprice rep said my method would work just as well).

    At first I attempted to connect to the components on the side of my TV (HDMI 4 plus a bunch of others including Red/White jacks for audio). Audio didn't work. I looked within System Preferences for Sound on the MBP with the TV connected and nothing pops up with regards to an audio out option for the Samsung speakers. I'm not sure if that is the issue or not however I'm assuming it is.

    I then attempted every other connection combination (HDMI 1,2,3 using every combination of Red/White audio jacks, no luck). With regards to video I've tried both mirroring the displays and just dragging the video file itself over to the TV and both times video is fine, audio is non existent.

    Your help would be greatly appreciated. I've ripped my entire collection via RipIt and really want to enjoy it on my new TV. Thanks.

    UPDATE:

    I'm also having an issue with "overscanning" when the TV and MBP are connected. It creates about an inch black border to the left and right of the screen. Stays this way during a movie playback while TV is connected to MBP. Any help on that front too would be very appreciated. Thanks.
     
  2. tombilske macrumors member

    tombilske

    Joined:
    Jan 31, 2010
    Location:
    Australia
    #2
    with the overscan thing, when you go into system preferences and then display, there should be a slider to control that

    and i know this sounds stupid but are you sure youre connected to the headphone jack and not the microphone jack?
     
  3. blairh thread starter macrumors 68030

    blairh

    Joined:
    Dec 11, 2007
    #3
    I could be wrong but I don't think a slider will fix the overscan issue. From what I'm reading online I think I need to change the aspect ratio on my TV. It's currently at 16:9.

    My MBP only has one audio in/out jack.
     

Share This Page