No Audio in AVI's after Apple TV 2.4 Update **FIX IN HERE**

Discussion in 'Apple TV and Home Theater' started by JoseJ, Jun 27, 2009.

  1. JoseJ macrumors newbie

    Jul 17, 2008
    Chorley, Lancs
    Thought I would bring this together in its own thread

    After updating to 2.4 all my non iTunes videos that are in iTunes (If you get my meaning) When I play them via streaming from my Mac now have no audio I have reinstalled the codecs as per 2.3.1 instructions and video is fine I can see the picture there is just no sound.

    I should point out that I do not use XBMC or Boxee as I prefer the Apple GUI so all I install from the patchstick is ssh tools so I can copy and move files from Terminal on my iMac.

    The videos I have in iTunes and were originally AVI's that I copied into Apple TV containers using a program called Video Drive (which I might add is an excellent investment @ €14.99)

    If anyone knows how to solve this (does the codec to to be moved somewhere else? XBMC and NitoTV users who are not experiencing problems might be able to check where codecs are installed in their new versions) that would be ace as there a few of us dotted around different threads looking for a fix

    Many thanks in advance :)
  2. delroy666 macrumors newbie

    Jul 24, 2007
    I'm in exactly the same boat. After the 2.4 update, I could ssh in to the Apple TV and reinstall the Perian codecs; video looks fine, but there is no audio when playing .avi files. I use the "Apple TV Fooler" script to wrap non-Quicktime files to sync to the Apple TV.

    I've restored back to my factory default version (2.0.1) for now. When I have some time, I'm going to try the latest beta version (1.1.4) of the Perian codecs and see if that works.
  3. JoseJ thread starter macrumors newbie

    Jul 17, 2008
    Chorley, Lancs
    You have any luck with that Perian Beta? I'm Still playing around with it no luck so far but its still early days yet. I think I have exhausted ever combination of 'No sound in AVI's after AppleTV 2.4 Update' in Google LOL:eek:
  4. delroy666 macrumors newbie

    Jul 24, 2007
    I tried Perian 1.1.4b1, but it didn't help... still no audio in AVI's on both analog output and over HDMI. I also installed NitoTV and used it to install Perian, but that just made things worse - I got no audio or video for AVI's, just a black screen.
  5. JoseJ thread starter macrumors newbie

    Jul 17, 2008
    Chorley, Lancs
    Still No Joy any help from NitoTV users who are not experiencing problems

    OK I have installed the newest version of the A52Codec.component in the following locations with no joy

    Library/Audio/Plug-Ins/Components/A52Codec.component (Where it was before the Update)

    and even created a new directory


    Is there any chance Apple could be blocking frontrow's access to the codec with a little bit of code in some obscure little file. I'm afraid the past week has been self teaching myself Terminal code and my knowledge is very limited to just copying files in moving them around and changing access permissions.

    If there are any Nito TV users out there who have 'FUGU' to visually check where files are located on their AppleTV, and have audio on their DivX encoded AVI's or anyone who could help us out that would be ACE!!!

    Regards Jay
  6. smersh macrumors newbie

    Aug 17, 2007
    I also downgraded to factory default. Where is A52codec supposed to go?
  7. delroy666 macrumors newbie

    Jul 24, 2007
    /Library/Audio/Plug-Ins/Components/ is where I put mine.

    I used the 'osupdate' tool to bring my factory-restored software (2.0.2 actually) back up to 2.3.1, so at least I have a recent OS version working with Perian until someone finds a solution to 2.4.
  8. vimesi macrumors newbie

    Jun 29, 2009
    Good day, Josej

    How can install update 2.3.1, the appletv automatic restore to 2.4?

    Best regards.
  9. h'biki macrumors regular

    Jan 14, 2003
    Sydney, Australia
    Hey Guys,

    I can confirm that this is a problem with the container trick that VideoDrive uses. Delete the AAC Sound track from the quicktime and it iwll work.

    UPDATE: If you delete the aac soundtrack, it will work fine... UNTIL the AppleTV resyncs its playlist. THen they will no longer sync.

    Sigh. Rock. Hard. Place.
  10. vimesi macrumors newbie

    Jun 29, 2009
    Excuse me I'm new, but, could you explain how delete de AAC sound track from quicktime.
  11. delroy666 macrumors newbie

    Jul 24, 2007
  12. delroy666 macrumors newbie

    Jul 24, 2007
    I'm using the "Apple TV Fooler" script instead of VideoDrive, which just appends a short .mov file to the beginning of the .avi. I'll try playing around with the audio format in this .mov file tonight and see if there's something that syncs AND plays in Perian on 2.4.
  13. outlyer macrumors newbie

    Jan 10, 2007
    If anyone is interested, I've got a fix that works now. It involves on change on the AppleTV and one on your Mac. On the AppleTV set the language to "English" under Settings->Audio & Video->Audio Language.

    Next, go into QuickTime and set the language of the AAC track in the fooler track to something other than English (i.e. French). This will allow the file to sync, but the AppleTV will skip over the French track and play the English MP3. It seems to work for me.
  14. delroy666 macrumors newbie

    Jul 24, 2007
    I can confirm this works. I used this script to change the audio of the AAC track in my .mov's to French, updated the Apple TV to 2.4 and set the audio language to English. After re-running the patchstick and installing Perian, I can now sync and play (with audio) my 'fooled' videos again.
  15. JoseJ thread starter macrumors newbie

    Jul 17, 2008
    Chorley, Lancs
    outlyer our SAIVIOUR

    :D:D:D:D:D:D:D:D Firstly let me congratulate both outlyer and delroy666 for their excellent work with this fix. Top Job!!!!

    Right I can confirm this fix also works with videos encoded with Video Drive. The following is step by step how I used both outlyer's and delroy666's posts to sort this out. All credit to them I take no credit for the fix I'm just putting it in a way that other folk like myself might understand.

    1. As per outlyer's instructions change the language on your AppleTV to English Settings->Audio & Video->Audio Language.

    2. Next open QuickTime and in preferences change it so that "movies open in a new window" IS checked AND 'Automatically begin playing when opened' IS NOT.

    3. What I found easiest was if like me your videos are neatly sorted into folders for show and season. Select all the shows from one season and open them. I did them in batches of 8 (Videos not Seasons:p)

    4. Next click at the top QuickTime Player->Services->ScriptEditor->Make New Script.

    5. Delete anything pertaining to file location in the big box so it is blank and copy the script from the link on delroy666's above post into the editor.

    6. Hit RUN and then close your videos one at a time. Your videos should now ask you if you want to save changes click SAVE on the all they should close after you click. Once all the videos in each batch is closed you should get a little 'All Done' dialog box. **You may get an error don't worry just click OK it still worked**

    Once this is done (It's a little time consuming but nowhere near as bad a recoding all your files:eek:) Your videos should now work with sound on your AppleTV

    If anyone else come up with a more efficient way feel free to put me in my place:p

    Thanks again to outlyer and delroy666!! Remote App with MY videos ACE!!!!
  16. piksel macrumors newbie

    Jul 3, 2009
    Thanks also to outlyer (for the solution) and delroy666 (for the link to the script). I have done this for my existing files.

    What I wanted to do was figure out how to update "Apple TV" so that it would automatically create a mov with the AAC track already set to French.

    It was very easy...

    1. Right-click the Apple TV file and select "Show Package Contents"
    2. Navigate to Contents/Resources
    3. Double-click the "" file to open it in Quicktime
    4. Press "CMD + J" to open the Properties for the movie (I think you need Quicktime Pro for this - if that's the case, try using the script that delroy666 links to above and skip the next steps)
    5. Select the Sound Track (Format should say AAC)
    6. Click the "Other Settings" tab
    7. Change the language to French
    8. Save and Quit Quicktime

    That's it... next time you use Apple TV Fooler it will create a movie with audio track 1 already set to French.
  17. JoseJ thread starter macrumors newbie

    Jul 17, 2008
    Chorley, Lancs
  18. smersh macrumors newbie

    Aug 17, 2007
    just dropping a line to confirm this fix works. Thank you.

    However, I have noticed that my ATV crashes a lot now. By a lot, I mean that I've had to restart it three times in the past week.

    I've never had to do that before. Anyone else notice this?
  19. delroy666 macrumors newbie

    Jul 24, 2007
    I haven't had any unusual crashing since updating to 2.4. Which version of Perian are you using? (I'm using 1.1.3)

    Mine crashes if I try to rewind while watching an .avi file, but it has always done that. HD .mkv's crash it too, so I just transcode those.
  20. smersh macrumors newbie

    Aug 17, 2007
    I'm using 1.1.3 as well. I guess it's been crashing on rewind, but I didn't make the connection. I never really had it crash on rewind before.

    But, then again, I never rewound it the way I have been in 2.4

    thanks for that.
  21. ethen macrumors regular

    Dec 5, 2005

Share This Page