No audio in .mpg's in QT

Discussion in 'Mac Apps and Mac App Store' started by V Dub You1972, Sep 3, 2007.

  1. V Dub You1972 macrumors newbie

    Joined:
    Jun 22, 2006
    #1
    Here is the problem:

    Quicktime will not play any audio when viewing a .mpg movie. It works with .mov, .mp4, .avi, and .wmv. It hasn't always been like this though, only for the past week or so. I know the files have sound in them because it works with VLC. Same thing happens when trying to play streaming .mpg's in safari. Any help would be great.
     
  2. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #2
    This is a rare problem that most Mac users have never seen. For us, .mpg files play audio just fine in the QuickTime Player and every other app. Is there anything unique about your particular problematic files? You select the Window > Show Movie Properties menu item and go through each tab. If there isn't something stupid like having the audio muted, report back what it says.
     
  3. V Dub You1972 thread starter macrumors newbie

    Joined:
    Jun 22, 2006
    #3
    Well movie properties is for Pro only but I looked under movie inspector and it said the format is MPEG1 Muxed. I don't know what the Muxed means though. It's the same for all my .mpg movies not just one particular file if hat helps.
     
  4. MikeTheC Guest

    MikeTheC

    Joined:
    Apr 26, 2004
    Location:
    Gallifrey -- Capitol City, Prydonian Sector
    #4
    Well, I hate to contradict the prior poster, but that is not technically the case.

    For any media player to be able to play a file, codecs appropriate to that file must be installed for the player to be able to handle it.

    And, odd as it may seem, the video component and audio component of a given multimedia file are TWO COMPLETELY DIFFERENT THINGS. That is, you may be able to hear audio but not see video, or the reverse (in addition, of course, to not being able to handle the file at all).

    You can download and install either Flip4Mac and/or Perian, which will provide you with a pile of codecs for QuickTime.

    You can also download the latest version of VLC, which comes with a right-enormous number of codecs.

    You can also also download the latest version of MPlayer for Mac OS X, though it's a bit rough in certain respect.

    You can do any or all three of these things (since they will not step on each other) and then pick and choose based on what player handles a given file the best.
     
  5. V Dub You1972 thread starter macrumors newbie

    Joined:
    Jun 22, 2006
    #5
    I have Flip4mac.

    I also have VLC. Which the .mpg's have sound in so I know they work.

    I would like them to work in Quicktime so they will also work while streaming in safari. Like I said before, it was working fine about a week ago. I don't have any clue on why its not working now.

    Also, while the video is playing the equalizer shows nothing. The volume slider is all the way up and the sound on the computer is up as well, I'm not that dumb :)
     
  6. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #6
    Mux means MUltipleX. Such files have their audio and video multiplexed into a single track. MPEG-1 Multiplexed is a very old format which every installation of the QuickTime Player since probably QuickTime 3--certainly QuickTime 4--can play out-of-the-box.
     
  7. V Dub You1972 thread starter macrumors newbie

    Joined:
    Jun 22, 2006
    #7
    I just tried downloading and re-installing the newest version of Quicktime but that didn't solve anything. I've run out of idea's on how to fix it.
     
  8. V Dub You1972 thread starter macrumors newbie

    Joined:
    Jun 22, 2006
    #8
    I FIX IT!

    I tried to play Age of Empires 3 but a message popped up and it told me to go to the Audio MIDI Setup under utilities and make sure the audio output is set at 44 kHz, which it wasn't. It was at 96 kHz. So it works now. Thanks for trying to help! I still don't know how that got changed though.
     
  9. spinksj macrumors newbie

    Joined:
    Sep 12, 2007
    #9
    Exactly the same problem after using Bluetooth Headset

    I had exactly the same issue after using a Nokia bluetooth headset on my MacBook Pro with 10.4.10.

    It initially start showed up as errors relating to my default audio device and Quicktime stopped playing MPEG-1 with sound.

    I tried removing all of my Quicktime plugins and perian as I though that one of them may have cached my since removed bluetooth headset as the audio output.

    This didn't work but I found this thread after a google search and tried the MIDI setup options thing.. I didn't think it would work but it has.. Even the game I was playing which complained about the default audio device has stopped complaining.

    Applications / Utilities / Audio MIDI Setup

    Then select Built-In Output in the Properties For:

    Even though it was set on 44khz I just clicked on Configure Speakers and then clicked apply and it asked me to save changes...

    It all works now as normal! Not really sure how it got changed though but I'm going to put it down to the magic of 10.4.10.
     

Share This Page