"No Batteries Available"

Discussion in 'MacBook Pro' started by PsychoLamb, Nov 27, 2006.

  1. PsychoLamb macrumors newbie

    Aug 21, 2006
    This September I bought my first Mac, a MacBook, for my first year of Univeristy.

    Everything was working fine until yesterday when I decided to download the latest firmware update.

    Upon doing this, neither did the firmware install but now my MacBook can't recognize the internal battery and it gives me the message "no batteries available." The fans also run constantly, no matter what the system is doing.

    I've reset the PMU, the NVRAM, reinstalled the OS. Let the battery drain to zero. Everything. Is their something I'm missing that'll resolve the problem?

    As you can imagine, I'm not the happiest of campers at the moment :(
  2. iGary Guest


    May 26, 2004
    Randy's House
    Call AppleCare. :)
  3. smueboy macrumors 6502a


    Oct 30, 2006
    I take it that you have tried simply removing the battery, and then putting it back? My PB stops recognising the battery occasionally (i get the 'X'), and all i do is remove the battery and then put it back while the computer is on and plugged in. Just a thought.
  4. richard4339 macrumors 6502a


    Sep 6, 2006
    This sounds like the winning thought, assuming you haven't already tried:

    In all honesty, always try to reset the machine using the battery. If all else fails, call tech support. If you've only had it for two months, then they should (in theory) get it fixed.
  5. PsychoLamb thread starter macrumors newbie

    Aug 21, 2006
    Called the support line, I've apparently done everything I can. I have to bring it in for repair *sigh*

    Thanks anways guys :)
  6. Westside guy macrumors 603

    Westside guy

    Oct 15, 2003
    The soggy side of the Pacific NW
    Interesting - when I woke my MBP up from sleep this evening, I had that exact same message. Rebooting fixed it in my case, fortunately; but I've never seen that happen before.

Share This Page