"No batteries found" after replacing HDD with SSD

Discussion in 'MacBook Pro' started by TheAceFromSpace, Jul 29, 2012.

  1. TheAceFromSpace macrumors newbie

    Joined:
    Jul 29, 2012
    #1
    Yesterday I replaced my HDD of my MacBook Pro 2011 with a SDD. After I unhooked the battery connector and replaced the HDD with the SSD, hooked the battery up again and installed mountain lion from a bootable disk my MBP gave me the no batteries available warning. After trying everything possible from reattaching the battery to pram zapping and putting the HDD back in I tried the SMC mode.

    After entering the SMC mode and restarting it in SMC mode it runs without AC power just fine so the battery ain't dead. The connector is fine because else the battery won't transfer power.

    Once your out of SMC mode it will only run on AC power.

    So I've tried it all and came to the conclusion that the battery is fine but it won't get detected by the computer.

    Does anyone know a solution?
     
  2. Dangerous Theory macrumors 68000

    Joined:
    Jul 28, 2011
    Location:
    UK
    #2
    Put the HDD back in and check if it works with that, to narrow down possible causes.
     
  3. striker33 macrumors 65816

    striker33

    Joined:
    Aug 6, 2010
    #3
    Are you sure you replaced the HDD, and not the battery by mistake? :rolleyes:
     
  4. TheAceFromSpace thread starter macrumors newbie

    Joined:
    Jul 29, 2012
    #4
    Yeah i've tried that also. I've put the HDD back with no result. I disconnected and reconnected the battery. But the only way it runs on battery is in SMC mode. The blinking sleeplight (6x) on startup also confirm that the battery needs service. But the strangest thing is that the battery is not dead but the computer just can't find the hardware.
     

Share This Page