"No battery detected" on macbook 2006 please help will only run on mains!

Discussion in 'Mac Basics and Help' started by jake020793, Dec 24, 2009.

  1. jake020793 macrumors newbie

    Joined:
    Oct 30, 2009
    #1
    I have a white macbook 1,1 earliest model. the macbook worked fine yesterday apart from the disc drive. the disc drive took in discs then just ejected them straight away. i took apart my macbook and took a look at the drive i managed to fix it and put everything back together. however now when i run my macbook (on windows 7 ultimate) it can only start when i connect it to the mains. there is a red "X" through the battery and says no battery detected. i want to know if anyone knows how to ix it? the battery and logic board are brand new so it is none of this, i was wondering if i might have forgot to put something back when i put it together, would this be the problem? also when i plug in the magsafe adapter it goes instantly orange so it says its charging but when i click on the button on the battery the first light just continues to flash. please help!
     
  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #2
    Yes, that would be a good guess.
     
  3. toolbox macrumors 68020

    toolbox

    Joined:
    Oct 6, 2007
    Location:
    Australia (WA)
    #3
    I just pulled one of these apart the other day for the same problem DVD drive was not reading cds.

    From memory there is a cable going from the battery connection onto the motherboard. If that wasn't plugged in properly then the mac can't detect it. Might be worth removing the top casing again and having a look.
     
  4. jake020793 thread starter macrumors newbie

    Joined:
    Oct 30, 2009
    #4
    thanks, i will try this and keep u posted, thanks :)
     

Share This Page