Resolved No Bluetooth after 10.10.2 Update

Discussion in 'OS X Yosemite (10.10)' started by DirtySocks85, Jan 31, 2015.

  1. DirtySocks85 macrumors 65816

    DirtySocks85

    Joined:
    Mar 12, 2009
    Location:
    Wichita, KS
    #1
    So, I updated to 10.10.2 last night on my 13" mid-2010 MacBook Pro, and now my MacBook says that Bluetooth is not available, and it says "no information available" under the Bluetooth section of the System Profiler. Has this happened to anyone else? How can I fix this? I've already tried restarting twice.

    ----------

    Never mind - an SMC Reset fixed the problem. Still... ugh.
     
  2. DeltaMac, Jan 31, 2015
    Last edited: Jan 31, 2015

    DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #2
    Right now your Bluetooth hardware, for whatever reason is not detected by the system.
    Try a PRAM reset: http://support.apple.com/kb/PH18761
    Try an SMC reset: http://support.apple.com/kb/PH18761

    Both are hardware resets of various levels.

    If that doesn't help, I would suggest a reinstall of OS X. If you did a simple update (and you were already running Yosemite), then a reinstall would assure that everything in the system software is correctly installed.
    Since 10.7 and later OS X versions, a reinstall is pretty quick. Install to an SSD from a USB device will probably take less than about 15 minutes. Then a simple check for additional updates (there will be a couple), and you are done, likely in less than 30 minutes.

    Get the full Yosemite installer from the App Store. Don't let the installer begin the install before you backup the installer app, and make a bootable USB flash drive. There's steps available for how to do that (using some terminal commands), or, easier, is to use the DiskmakerX app that you can download.
    http://diskmakerx.com
    DiskmakerX makes a nice Yosemite installer to keep on an 8GB flash drive.

    After all that - Still no bluetooth? You will need support from Apple (and you are out of warranty, too) Likely just needs the bluetooth card...
    And, that's not as simple as it sounds. Just checked in a service manual, and the bluetooth is inside the display assembly (the clamshell) The wiring runs through the hinge area, and you can try reseating the camera connecter on the logic board, as camera/wifi/bluetooth connections all run through that connector.
    Well, I hope the PRAM reset fixes it first !
     

Share This Page