No Bootable Device Boot Camp Issue

Discussion in 'Windows, Linux & Others on the Mac' started by Omek, Feb 17, 2013.

  1. Omek macrumors regular

    Joined:
    Jun 6, 2003
    #1
    I'm getting the "no bootable device," error every time I try to partition and install Windows 7 on my Macbook Pro (early 2011). I followed all the instructions to make my Boot Camp app make a USB flash drive Windows 7 boot disk. All I have is a few 16GB Toshiba flash drives but neither work.

    Additionally, I tried using the Windows7-USB-DVD-tool on my flash drive on a Windows 8 virtual machine in Parallels. It was successful, but I tried installing via Bootcamp, and I get the same error message. Any ideas on getting this flash drive to work? I think it's ridiculous that I can use these flash drives as boot disks for everything else except when it comes to DOS and Windows.

    "no bootable device" problem:
    http://www.youtube.com/watch?v=NgWBY6IezQA

    I tried doing as he suggested, holding option on startup to see if my Mac would recognize the disk as a startup disk, but the flash drive doesn't show up. This drive has been formatted, so I don't understand why it can't be used as a boot disk.

    I also tried plugging it in both of my USB ports a few times, and the light doesn't even blink, so I know the Macbook is not reading the flash drive. Although, it does show up on my desktop when I boot up in Mountain Lion.

    I'd try and buy some other flash drive brands, but I'm also seeing forums on here and elsewhere that say people have tried several other brands and have gotten the same "no bootable device" error.

    Here are the instructions I followed to create the boot disk:
    http://www.youtube.com/watch?v=QFIWtXTl4d0&list=PL8B6C2C72E7CCCC45&index=1
     
  2. duen macrumors newbie

    Joined:
    Feb 18, 2013
    #2
    having the same issue on my 2008 mbpro. last night i decided to do a fresh install of both my mac and windows partitions (like to do that every couple of years). installed the mac partition fine, went into boot camp assistant to begin installing windows.

    restarts, goes right into "no bootable device" screen. assuming it needed the windows install disk, i tried ejecting in order to swap out the mac install disk which was still in there. nothin. tried every force eject method i could think of. nothing. tried booting up the comp holding option/alt, tried while holding C, etc etc. disk still refused to come out and still stuck on this no bootable device.

    took it down to geek squad to get the disk removed manually. they removed it, but didn't have any suggestions from there. they in fact suggested i put the disk back in to see if it got stuck again. it did, of course.

    we removed the disk again, they said it could possibly be the superdrive messed up. which is odd cause i just installed the mac os fine moments before, and had ejected a game disk to insert the mac os install disk, fine.

    thought maybe they keyboard was not responding, so i plugged in another keyboard. same result.

    the only other thing i could think of is that the disk itself has been screwed up, (which happened before with the leopard install disk, urging me to go out and get the snow leopard one).

    however i'm indecisive about popping the windows install disk in instead, just in case THAT gets stuck, and apparently last time they forcibly removed the disk it damaged it a bit, and we all know how much more expensive the windows os is compared to mac's. lol.

    anyway just wanted to let you know you're not the only one with this problem right now and it's extremely frustrating when all the solutions are "hold down option" when that doesn't do anything, ha!
     
  3. Omek thread starter macrumors regular

    Joined:
    Jun 6, 2003
    #3
    Thanks, duen! Good to know I'm not the only one with this issue. I was about to go out and buy a bunch of other flash drives, but clearly, that might not work either. Perhaps Apple will fix it in the upcoming 10.8.3 update. Their spec notes also state that Boot Camp will officially support Windows 8 in this update.

    ----------

    There's also a thread over on Apple's support forums with several other people having the same issues. They're saying it might have something to do with Apple's USB firmware on newer Macbook Pros:

    https://discussions.apple.com/message/16527427#16527427
     
  4. duen macrumors newbie

    Joined:
    Feb 18, 2013
    #4
    just out of curiosity, since i got the disk out of the drive, i put in my old hard drive and attempted to boot into the mac partition again using option. success!

    turns out my superdrive is fine and the install disk was somehow mucking up the entire system. will be kind of a pain since the best buy here doesn't carry mac os install disks and i need it to install the bootcamp drivers. i heard you can download them somewhere so i'll be looking into that.

    as for your problem, do you possibly have any disks in the drive that could be screwing with you at all? i know it sounds odd but that's what was causing mine. or perhaps since you are using the usb instead, it could be something wrong with the files that it's not recognizing.

    i'm no genius so i can only guess based off of what was wrong with mine. :/
     
  5. Omek thread starter macrumors regular

    Joined:
    Jun 6, 2003
    #5
    Well, I'm glad you ended up fixing your problem. I did find a post in that forum that involves a lot of tinkering, but I'm just going to skip it and try a disc instead.
     

Share This Page