No bootable device -- Insert boot disk and press any key

Discussion in 'Mac Basics and Help' started by yangyang, Jan 20, 2010.

  1. yangyang macrumors newbie


    Jan 20, 2010
    Firstly, I hope this is the right section to post this. Secondly, It's either I'm really blind because I didn't see any post which is related to mine? Thanks in advance.

    Alright, here's what happened. I tried downloading Windows 7 on my MacBook, new user btw. I thought the installation was working until it shows a black screen stating "No bootable device -- Insert boot disk and press any key" I pressed 'control + command + start up button' and it was back to normal until again it showed up the same black screen with what's stated in my title. I know one way is to press 'option + start up button', then I have to click Macintosh HD and it's back to normal again.

    Apologies for the nags before lol. What I wanna ask is are there any ways to stop having the black screen stating "No bootable device -- Insert boot disk and press any key" whenever I start up my MacBook? Cause I kept having the black screen stating that sentence when I turn on my Mac.

    Thanks again.
  2. cderalow macrumors 6502



    run bootcamp and delete the attempted windows partition.
  3. flynz4 macrumors 68040

    Aug 9, 2009
    Portland, OR

    Choose: System Preferences > Startup Disk and select your Mac partition as the default boot disk.

  4. yangyang thread starter macrumors newbie


    Jan 20, 2010
  5. jon08 macrumors 68000

    Nov 14, 2008
    Hey guys, let me borrow this thread real quick.

    Yesterday I tried to install Windows 7 through bootcamp, but OS X kept ejecting the install DVD. When I tried to leave the DVD in and restart right away, I would get the gray screen (without apple) and then the black screen with the above-mentioned msg.

    Although I did get back to OS X eventually, what bothers me more is that I cannot get Windows 7 to install - it's either that msg, or sometimes I just get black screen with a blinking cursor in the upper left corner, but mostly the DVD simply gets ejected.

    What the hell? There's nothing wrong with DVD - it boots fine when I inserted it in a PC, and it worked darn fine in Leopard's BootCamp.

    What the hell is up with Snow Leopard, or what is it that it won't let me install Windows??
  6. TheChristoph macrumors newbie

    Jul 1, 2007
    jon08, I am experiencing the EXACT same situation, except with Windows XPSP2, not Win7. It worked in Leopard, the only thing different is that I've upgraded to Snow Leopard.

Share This Page