No Bootable Device - USB Install Bootcamp Error

Discussion in 'Windows, Linux & Others on the Mac' started by CloneOutcast, Nov 23, 2014.

  1. CloneOutcast macrumors newbie

    CloneOutcast

    Joined:
    Nov 23, 2014
    #1
    So, I've been trying to install Windows 8.1 x64 on my Mid 2011 iMac and I keep running in to the same problem where after my machine restarts after the Windows partition is made it says "No bootable device...".

    Basically, I found a way to let Bootcamp make a bootable USB since my iMac no longer supported it. I edited the info.plist so that the option was available to me.

    Once I went through all the steps of formatting the USB to FAT and making it a Windows install and partitioning, my machine finally restarted to install Windows.

    After that I got the "No Bootable Device" prompt. I have tried holding the Option key and selecting the USB to boot from but I get the same results. I've also tried installing from different USBs/HDD with no success. Also, only one external drive is connected to my computer at a time.

    Is there anyway to fix this issue or is it unavoidable because my machine has an OpticalDrive?

    Currently I can't find any simple fixes for this specific problem aside from buying blank CDs and burning the Windows ISO on to a disk.
     
  2. saturnotaku macrumors 68000

    Joined:
    Mar 4, 2013
    #2
    That is your only quick fix if your Mac has an optical drive. There is a solution that involves using VMWare fusion, creating virtual machines, and a whole lot of futzing around. I know it's much harder to remove the optical drive on an iMac, but on my MacBook Pro, I've gotten so good at it that it takes me less time to swap hardware than whatever lengthy software workaround is in place to install Windows without a DVD.

    Editing that plist file only makes a previously grayed out checkbox accessible. It does nothing to address the firmware limitation Apple has placed on these machines that forces a Windows installation from the Superdrive on models so equipped.
     

Share This Page