No Carrier after Jailbreaking to 4.3.1?

Discussion in 'Jailbreaks and iOS Hacks' started by themat, Apr 4, 2011.

  1. themat macrumors member

    Joined:
    Dec 27, 2008
    Location:
    Manchester, UK
    #1
    Upgraded earlier to 4.3.1 using Redsn0w and now everything seems to have gone completely wrong, had some small problems initially. However, once I got everything working my iPhone 4 boots up fine, but where my carrier should be (Vodafone) there is just a blank space and sometimes "No Service" appears. I've not been able to send messages or make phone calls since.

    Have tried re-jailbreaking again but nothing changes and have obviously tried restoring using iTunes but that fails towards the end. My general settings tells me my baseband is 04.10.01.

    Any ideas please? I have no idea what else to do.
     
  2. dr.george macrumors newbie

    Joined:
    Jun 23, 2010
    #2
    Same here... just reseted network settings and nothing..
     
  3. trunglippo macrumors newbie

    Joined:
    Jan 27, 2011
    #3
    I have the same problem, no service after JB for 4.3. Cydia works fine, all apps are working fine, too. But I cannot make a call or text a message. I use the Turbo Sim though. I have to restore the phone again, and it works fine without JB. Does anyone know what is going on?

    Thanks
     
  4. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #4
    Is your phone factory unlock?

    It's seen like you have update your iphone firmware through Itunes to 4.3.1 where it also updated baseband to 04.10.01. If your phone is not factory unlocked, then by updating through Itunes to the latest firmware/baseband, you have loose the unlock.
     
  5. lazygregg macrumors member

    Joined:
    Jun 19, 2007
    #5
    same issue as all of you

    4.3.1
    modem firmware 03.10.01
     
  6. nidserz macrumors 6502a

    nidserz

    Joined:
    Mar 28, 2008
    Location:
    Dubai x Toronto
    #6
    Had the same issue when trying to preserve my baseband... I updated through iTunes then jailbroke and it worked...
    Something to do with keeping the baseband I think. Not sure, but I think some people have been successful; I wasn't but luckily don't need to cuz my phone is factory unlocked.
     
  7. lazygregg macrumors member

    Joined:
    Jun 19, 2007
    #7

    restored my iphone but when i try to use the custom firmware after going into dfu mode it says iphone cannot be restored :(
     

Share This Page