No Cellular After iOS 5 Install

Discussion in 'Jailbreaks and iOS Hacks' started by ibanez81, Jun 10, 2011.

  1. ibanez81 macrumors newbie

    Joined:
    Dec 21, 2010
    #1
    Thought I would post this here as well...apologies for the redundancy.


    I have been using my iPhone 4 with iOS 4.3.2 jailbroken through PWNAGE Tool 4.3.2.

    I decided to use the iTunes 10.5 beta to install iOS 5 to check it out and quickly realized how unusable it is this early in the development. So I restored my iPhone 4 to the official iOS 4.3.3 and then used PWNAGE Tool v4.3.3 to create the custom firmware. Once installed, everything works on the iPhone except the cellular connection to AT&T.

    At the moment I am running my iPhone with the official iOS 4.3.3 and it works as it should.

    Troubleshooting so far:
    - Restored to official iOS 4.3.3 then created the custom firmware again and installed without the SIM card in
    - Verified the Modem Firmware (Baseband) is still 04.10.01
    - Not sure if my IMEI or ICCID would have changed due to using iOS5 and connecting to AT&T's network (I don't think it could connect anyways)
    - Tried resetting the iPhone through Settings (Reset All Settings, Reset Network Settings)

    Questions:
    - Is there any other software on the iPhone that would prevent my SIM from connecting to AT&T's network when running iOS 4.3.3 jailbroken?
    - Would restoring/upgrading with iTunes 10.3.1 versus iTunes 10.5 beta make any difference?

    Any thoughts on this is appreciated.

    Thanks.
     
  2. Armeniandave macrumors 6502

    Joined:
    Jun 12, 2010
    Location:
    San Diego
    #2
    By default it's hacktivated. Rejailbreak and uncheck the activation in the general settings in PWNG tool.
     
  3. ibanez81 thread starter macrumors newbie

    Joined:
    Dec 21, 2010
    #3
    Thanks...

    Worked like a charm.

    Thank you for the suggestion.
     

Share This Page