No Cellular Data on iPhone X + iOS 12 GM + AT&T

TypeMRT

macrumors 6502
Original poster
Sep 7, 2007
464
86
Upgraded from 11.4 to 12 GM last night and didn’t notice until this morning that cellular data wasn’t working because I was using Wi-Fi at home. AT&T LTE shows the normal range of signal strength and calls worked just fine during my regular commute to work. Toggling Airplane Mode & Cellular Data didn’t change anything. Full reboot seems to have solved it.
 

chrismac2

macrumors regular
Jan 14, 2008
172
153
Seattle, WA
Upgraded from 11.4 to 12 GM last night and didn’t notice until this morning that cellular data wasn’t working because I was using Wi-Fi at home. AT&T LTE shows the normal range of signal strength and calls worked just fine during my regular commute to work. Toggling Airplane Mode & Cellular Data didn’t change anything. Full reboot seems to have solved it.
This has been happening to me too for many betas now.....reported to Apple via Feedback. The only fix is always a reboot. Toggling Airplane mode does not fix it.
 

chrismac2

macrumors regular
Jan 14, 2008
172
153
Seattle, WA
Upgraded from 11.4 to 12 GM last night and didn’t notice until this morning that cellular data wasn’t working because I was using Wi-Fi at home. AT&T LTE shows the normal range of signal strength and calls worked just fine during my regular commute to work. Toggling Airplane Mode & Cellular Data didn’t change anything. Full reboot seems to have solved it.
This has been happening to me too for many betas now.....reported to Apple via Feedback. The only fix is always a reboot. Toggling Airplane mode does not fix it.
Just got a carrier update from ATT now after the public release. It’s 33.1. Maybe it fixes this.
excellent! here's hoping!
 

chrismac2

macrumors regular
Jan 14, 2008
172
153
Seattle, WA
This has been happening to me too for many betas now.....reported to Apple via Feedback. The only fix is always a reboot. Toggling Airplane mode does not fix it.


excellent! here's hoping!
The carrier update today from AT&T did not fix it for me. Just got out of Seattle’s light rail tunnel to full LTE bars but no internet. Toggling airplane mode did not help. Had to turn phone off and on to get data back.

Damn.
 

wesley96

macrumors 6502
Sep 21, 2009
326
162
Exactly the same thing happens to me with the LTE connection on SK Telecom (largest South Korean carrier) with my iPhone X running iOS 12 GM. Signal bar is full, voice calling works, but about once a day the cellular data simply stops working. Full reboot is required to return to service. Maybe it's a bug in the iOS or the baseband software?
 

nealh

macrumors 6502
Jul 20, 2010
471
29
I’m finding signal strength seems to be worse as well.

This is very disappointing
 

imagineadam

macrumors 65816
Jan 19, 2011
1,397
586
So far so good for me with 33.2.
[doublepost=1537648195][/doublepost]Woah. Literally after I posted that my phone went to Searching... but then the signal came right back and it seems fine. Didn’t need to reboot this time. I wonder if my cell antenna is starting to go on my 7 after 2 years? Just weird how it all started after my update to iOS 12......
 

chrismac2

macrumors regular
Jan 14, 2008
172
153
Seattle, WA
Update, it is still happening to me on my new phone with the latest AT&T carrier update 33.2. Lost data connection after leaving wifi. Had to reboot phone.
 

IowaLynn

macrumors 68000
Feb 22, 2015
1,556
356
Running 12.1 and AT&T 33.5.2
The SIM card was issued in March if that matters.
 

jpiszcz

macrumors 6502
Mar 28, 2010
321
61
Ran into the same issue here, LTE service but no data (no IP assigned, etc), reboot, then it is fine (AT&T), never saw this issue with iOS < 12
 

nealh

macrumors 6502
Jul 20, 2010
471
29
I am convinced my Wi-Fi and cellular performance has degraded

Even my new iPhone Xs Max Is performing worse
 

imagineadam

macrumors 65816
Jan 19, 2011
1,397
586
Update, it is still happening to me on my new phone with the latest AT&T carrier update 33.2. Lost data connection after leaving wifi. Had to reboot phone.
Just happened to me again. This seems to be and iOS 12 problem. Mine happened randomly with my WiFi off. All of a sudden it went to searching then came back and says can’t activate cellular network. Only fix it to reboot and wait for it to happen again.
 
  • Like
Reactions: nealh

nealh

macrumors 6502
Jul 20, 2010
471
29
Just happened to me again. This seems to be and iOS 12 problem. Mine happened randomly with my WiFi off. All of a sudden it went to searching then came back and says can’t activate cellular network. Only fix it to reboot and wait for it to happen again.
I agree
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.