No Cellular Data

Discussion in 'iPhone' started by whodini, Sep 19, 2014.

  1. whodini macrumors newbie

    Aug 5, 2011
    Upgraded from a 4s to a shiny new 6. Activation seemed to go fine. I can make calls, and it shows LTE up top, but when I try to use cellular data I get Could Not Activate Cellular Data Network. Called AT&T and did all the usual stuff - reset network settings, rebooted a few times, etc. CS was really nice but ultimately had to put a ticket in.

    Anyone else seen this? Could it be a bad SIM?
  2. jeffxdy macrumors newbie

    Sep 12, 2014
    Hi, I've got the same problem but cannot solve it. :mad:
  3. AutoUnion39 macrumors 601


    Jun 21, 2010
  4. Appl3FTW macrumors 603


    Nov 15, 2012
    so the problem is data using LTE? hmm let me try that. i've been on wifi all day.
  5. ZBoater macrumors G3


    Jul 2, 2007
    Sunny Florida
  6. xraydoc macrumors demi-god


    Oct 9, 2005
    Take it to an AT&T corporate-owned store (not an authorized retailer store) and have them change the SIM. There's a provisioning issue in there somewhere and the telephone customer reps are usually idiots.

    I have an iPhone 5S on which I could not turn on FaceTime over cellular nor turn on the hotspot feature. Phone said to call AT&T. Called. The CS rep eventually told me that I was using an Android SIM card and that it wasn't fully compatible and that I needed a new Apple SIM card. Huh??

    Went to my local AT&T store and they could see it wasn't provisioned properly at their end and that the CS rep could have fixed it over the phone if she knew what she was doing. While a SIM swap wasn't necessary, the easiest way for the store to fix it would be to change the SIM and re-enter the phone's IMEM number, etc.

    3 minutes and I was out the door with all services working.
  7. jeffxdy, Sep 20, 2014
    Last edited: Sep 20, 2014

    jeffxdy macrumors newbie

    Sep 12, 2014
    I went to the AT&T store and the rep found my IMEI number was still the default value, a series of ones. After he reentered my IMEI, the problem was solved. :)

Share This Page