No connection to wireless router on one machine.

Discussion in 'Mac Accessories' started by echristie, Sep 17, 2009.

  1. echristie macrumors newbie

    Joined:
    Jul 13, 2005
    #1
    My wireless system has worked flawlessly for 3 years. My Linksys wireless router reset itself to default settings this week (due to power cut) so I had unsecured network for a few days. My internet provider came out today and updated firmware etc and reprogrammed it to the secure settings it should have.
    Now my iMac (10.4.11) sees the network but will not connect. Strangely iBook (10.5.5) and iPhone are working perfectly. The iMac recognised and connected fine to the unsecured network right up to when the tech man came. The Airport dropdown menu showing my network name does not have a padlock beside it on the iMac, but the padlock is there on the iBook.

    I have tried entering the router password manually but it says it is the wrong one. It is definitely the correct password.

    The whole system here is wireless (i.e. broadband is beamed wirelessly from a mast on a nearby mountain). In a few days I can take the iMac to another location to test it out on "conventional" cabled broadband with a wireless network in the house.

    I have tried the usual things, the only thing I cannot do is physically get to the router itself as it is in the loftspace in the house, but I can switch it on and off - but only by cutting the power supply to it.

    Any suggestions really welcome. My system was not actually broken but now it sure is. Grrrrr.
     
  2. SqB macrumors 6502

    Joined:
    Jan 14, 2008
    Location:
    Northern Colorado
    #2
    You may have already tried this, but if you havent...

    1. Go into the network settings under system preferences.
    2. Select your airport and click on the advanced button. You should see a list of your "preferred networks" and you will see the settings previously used for your home network.
    3. Click on that and press the minus (delete) button below the list to delete it.
    4. Click on ok at the bottom of the screen.
    5. Go up to the wireless icon and select "Turn airport off"
    6. Wait a few seconds and go back in and turn it on again
    7. Select your home network from the list and enter the proper password when prompted
     
  3. echristie thread starter macrumors newbie

    Joined:
    Jul 13, 2005
    #3
    Thanks, but I have tried that more or less. Under 10.4 I cannot see any Advanced button, but I do have it on the laptop (10.5). The problem machine in theory now has no network configured at all (under Syst Prefs) becasue I think I have managed to delete it, but the drop-down menu below the wireless icon still shows my home network. It never disappears no matter what I do.
    If I select it I just get the same frustrating error message.
    Any other ideas?
     

Share This Page