No data connection after update to iOS 4.0

Discussion in 'iPhone Tips, Help and Troubleshooting' started by DigitalD, Jun 17, 2010.

  1. DigitalD macrumors newbie

    Joined:
    Jun 17, 2010
    #1
    I did the update last night to 4.0 on my 3Gs (previously jailbroken with spirit). Everything appeared to work fine but now my can't connect to any cellular data. Regular phone calls work fine and so does data over wifi but if I switch to 3G or edge no web sites will load, can't connect to the app store, etc.

    I've tried doing the data services reset from the settings menu but that made no difference.
     
  2. CSMchris376 macrumors regular

    Joined:
    Mar 13, 2010
    Location:
    Illinois
    #2
    Doesn't iOS4 have a setting to turn off cellular data? Maybe you could check that setting. Otherwise, I wonder if just a reset of the iPhone would help. :confused:
     
  3. DigitalD thread starter macrumors newbie

    Joined:
    Jun 17, 2010
    #3
    Cell data is on (3G icon is up in the corner) and multiple resets have been done.
     
  4. CSMchris376 macrumors regular

    Joined:
    Mar 13, 2010
    Location:
    Illinois
    #4
    My only other suggestion then would be to contact AT&T and have them check your provisioning. They may need to do a data reset.
     
  5. jocal macrumors newbie

    Joined:
    Jun 16, 2010
    #5
    You said you've done multiple resets. Have you tried just turning the phone off and then turning it back on again after about 10-15 seconds?
     
  6. Noelmel macrumors regular

    Joined:
    Jun 2, 2009
    #6
    i have the exact same problem. saw another thread on this and they said they had "updated" to ios4 and you should "restore" to ios4. I also just "updated" so i am going to try and restore hopefully it will fix but i dont know if you are supposed to restore and backup or restore as a new phone?
     
  7. hexonxonx macrumors 601

    Joined:
    Jul 4, 2007
    Location:
    Denver Colorado
    #7
    Restoring my iPhone and the restoring my previous backup fixed this problem for me.
     
  8. Noelmel macrumors regular

    Joined:
    Jun 2, 2009
    #8
    it didnt work for me :( i didnt want to "set up as new phone" so i kepy restoring from my backups but everybackup that was made while i was jailbroken makes me loose all data connections. i then restored from a backup like from 6 months ago (the last one i made before jailbreaking) and that worked but i lost about 6 months worth of texts and app data!

    so it seems like any backup made when jailbroken is corrupted somehow??!!?
     
  9. DigitalD thread starter macrumors newbie

    Joined:
    Jun 17, 2010
    #9
    AT&T did a reprovision of my data settings and it didn't fix the problem. I've attempted both an upgrade and a restore on the phone. I'll work on it some more today and see if I can fix it.
     
  10. chris350 macrumors newbie

    Joined:
    Jun 21, 2010
    #10
    i have the same problem...no solution...may have to go to Apple to get it replaced...
     
  11. Noelmel macrumors regular

    Joined:
    Jun 2, 2009
    #11
    for me if you restore and backup from a backup that was made BEFORE i jailbroke it works. All my recent backups from while it was jailbroken have this problem. So i ended up having to use a backup from like 6 months ago (which was before i jailbroke) and that fixed it but i lost all my texts and app data from thoise 6 months :(
     
  12. trashy macrumors newbie

    Joined:
    Feb 2, 2007
    #12
    I evidently lost all backups when I selected upgrade as opposed to restore. When I tried restore, the only options were from a sync this afternoon - I did the iOS4 upgrade at lunch!

    Something tells me I may be hosed......
     
  13. Mindinversion macrumors 6502

    Mindinversion

    Joined:
    Oct 9, 2008
    #13
    Same issue with same pre-existing criteria:

    IE, jailbroken with spirit, upgraded to iOS4, lost Edge/3g [wifi worked]

    restoring from an earlier backup did not fix the issue, had to setup as a new device. Fortunately for me, all my information is backed up and either re-synced (calendar, contacts) or was due to be refreshed anyway (music/movies)

    There are reports on Apple's support forums that this is happening [if you believe the posters] with non jailbroken iPhones.

    http://discussions.apple.com/thread.jspa?threadID=2469538&start=0&tstart=0

    Whether they're telling the truth or afraid to admit to jailbreaking. . who can say ;)
     

Share This Page