No Data IP Address

Discussion in 'Jailbreaks and iOS Hacks' started by Gizmotoy, Mar 14, 2011.

  1. Gizmotoy, Mar 14, 2011
    Last edited: Mar 14, 2011

    Gizmotoy macrumors 65816

    Gizmotoy

    Joined:
    Nov 6, 2003
    #1
    So, recently I've been having trouble with my greenpoison iPhone 4 running 4.1. My status bar shows full AT&T signal, and the 3G indicator is on. However, no apps that access the internet can pull down any data. Today I realized that when this is happening, SBSettings shows my Data IP Address to be N/A.

    Has this happened to anyone else? I thought maybe it was 3G Unrestrictor since I didn't recall having this issue before I purchased that, but I seem to be seeing the same behavior even after uninstallation.

    I'm not exactly sure what is going on. Wifi works fine.

    Did I somehow muck up my APN settings? I don't think I know what they're supposed to be to verify that they're right. I do have TetherMe installed, but I had been using that quite a bit a few weeks ago, so it's definitely worked since it was installed.
     
  2. DGreenMan macrumors newbie

    Joined:
    Aug 5, 2011
    #2
    Hi there i have this problem also regarding Data IP Address shows up as N/A
    it has worked fine with no issues from releasse date but this arrised about 3-4 days ago out of the blue,

    but where your edata does not work (mine does) & your wifi does work (mine doesnt)

    :(

    did you find a fix for this ??

    or can any one else help pleaseeeeeeeeeee
     
  3. DGreenMan macrumors newbie

    Joined:
    Aug 5, 2011
    #3
    FIX

    Since i got no reply today i started playing on the router side of things instead of trying to fix it from my iphone,

    i found changing my network set up from wep to wpa it fixed the issue

    im with sky broadband so what i did was

    in internet browser/ firefox (what eva) type 192.168.0.1

    user name admin
    pass sky

    (sky will not give you that info the gits)

    go to wifi settings

    in security options change the selection you have now to a different one
    (also going back to the original set up later worked aswell)

    make a note of the network key

    click apply

    now reconnect all your wifi devices wto your wifi network with the network key you just made a not of and all is up and running


    like i mentioned above after doing this i put it back to its original settings (when the iphone would not connect to the net) and it also worked

    so why it wouldnt connect?? why it stop working ??

    but who cares really when it is now fixed YEY
     
  4. sleewok macrumors newbie

    Joined:
    Aug 8, 2011
    #4
    I'm having this issue as well. The previous post is unrelated to the original issue. This issue is in regards to 3G or Edge not receiving a data ip. I have no problem connecting via wifi. I had upgraded to IOS5 Beta 4, and have now downgraded to 4.3.3. The baseband is 4.10.01. My phone shows connection to 3G, but it never pulls a data IP (as shown in SBSettings). I tried to install the APN editor, but that fails at configuration during the Cydia install.

    I'm on AT&T.

    Thanks for any help!
     
  5. sleewok macrumors newbie

    Joined:
    Aug 8, 2011
    #5
    Fixed

    I was able to fix the problem using the following:

    1. Connect your iphone to WIFI
    2. Open Safari and browse to: http://www.unlockit.co.nz
    3. Create a config and select your Provider
    4. Install the certificate
    5. Reboot phone

    So it seems like the APN settings were broken for my phone.
     

Share This Page