No Desktop Icons

Discussion in 'macOS' started by billchase2, Feb 20, 2008.

  1. billchase2 macrumors 68000


    Feb 28, 2006
    Ann Arbor
    Okay, I'm having some problems with my Powerbook. Yesterday, I upgraded Firefox. When re-opening after the upgrade, I had a kernel panic. I restarted my computer and figured I would be good to go. Well, after logging back in, I found that Finder was acting up and I no longer had any desktop icons. Now, clicking the Finder icon in the dock will open a new Finder window just fine. If I go to the Desktop from there, all my icons are still there. So, I decided to restart my computer and see if that made a difference.

    After restarting, I ran into the same problem. I then decided to trash the Finder preferences and restart again. After restarting a second time, there still were no icons on my Desktop and my sound no longer worked (a problem I've been having after restarting occasionally). I verified the disk permissions and repaired the disk permissions (both took incredibly long... about 45 minutes each probably). When I restarted that time, I reset the PRAM (which is the trick I've found to fix my missing audio). When I got back to my Desktop screen, the icons were still missing but my audio was back.

    One of my friends recommended that I reset the PMU and that I also run the Disk Utility tools from my Leopard disk upon restart. Do these sound like my next steps? Does anyone else have any ideas?

    Thanks in advance!

    Weird... I'm not sure what happened but I fixed it.

    There was an option selected in TinkerTool that disabled my desktop. I definitely did not check that... but it somehow got enabled.

    Oh well, good to go now!
  2. Phasma Felis macrumors newbie

    Mar 1, 2010
    I recently solved a similar problem. I've seen quite a few people asking about it online, but no direct solutions, so I wanted to note it here.

    I was seeing absolutely no icons on my desktop, no lasso box appeared when I dragged, nothing. This was on a completely clean install of Snow Leopard. It turns out the option Bill mentioned had enabled itself somehow, even without TinkerTool installed. The solution is:

    • Install TinkerTool.
    • In the Finder tab, check "Disable Desktop Features", then click "Relaunch Finder".
    • Now, uncheck Disable Desktop Features and Relaunch Finder again.
    I have no idea how this happened, but Bill's mention of TinkerTool helped me track down the solution. Thanks, Bill!
  3. yusukeyamani macrumors newbie

    Feb 14, 2011
  4. Gregg2 macrumors 603

    May 22, 2008
    Milwaukee, WI
    I know, 2 years old, but...

    An app called TinkerTool just gives me a reason to stop and think, "Do I want to use this?" Can anybody think of a word that rhymes with Tool? ;)
  5. r0k macrumors 68040


    Mar 3, 2008
    I knew about relaunching Finder and that has worked for me a number of times, but there were a handful of times it didn't bring my desktop stuff back. Now I know to use tinkertool and relaunch again if it didn't work the first time. Nice hint. Thanks!
  6. thankful macrumors newbie

    Dec 12, 2012
    This is genius advice, thanks!


Share This Page