No discs will mount on Power PC

Discussion in 'PowerPC Macs' started by dakotaspurs, Jun 26, 2012.

  1. dakotaspurs, Jun 26, 2012
    Last edited: Jun 26, 2012

    dakotaspurs macrumors member

    Joined:
    Aug 24, 2011
    #1
    Hi everybody,

    My parent's own a third hand Power PC G4, the Dual 1.25GHz version, with 2GB RAM running 10.4.11.

    I have it in my office whilst they are on holiday as I said I would see if I could get it running quicker for them. I have done the usual bits of repairing the disc permissions and using disc utility to repair the disk, but I have come up against a problem.

    Whenever you turn on the machine it comes up with 2 errors of "Disk not readable" which I can only assume relate to the two disc drives that it has ... even though there are no discs in them.

    I also have the same error when I plug in any external HD.

    Another thing is that it won't mount any .dmg files, saying that there are "no mountable file systems". The default app to open them is set to the DiskImageMounter.app

    I was thinking that I should just wipe the OS and re-install, but I want to back-up the data and applications first, but of course can't load any new software to do this as it won't mount a .dmg file.

    I have also tried making a new Admin user, but no disks will mount under this user either.

    Does anyone know why this may be happening and what I can do to fix this mounting issue, or is the machine dead in that sense?

    Thanks in advance.
     
  2. Lil Chillbil macrumors 65816

    Lil Chillbil

    Joined:
    Jan 30, 2012
    Location:
    California
    #2
    Ok so your kinda S*** outa luck in the sense that your missing a driver and you need to re-install to get the driver back but you can't back up any information. So just accept that its gone and wipe and do a fresh install

    if you had any irreplacable data on there i'm very sorry for your loss:(
     
  3. CAINuKe macrumors newbie

    CAINuKe

    Joined:
    Jun 11, 2012
    Location:
    Toccoa, GA
    #3

    You can do this, but it,
    Go find a could app like dropbox or something like zumodrive, they install sometimes as a .apk,if it is a DMG. Go find a windows machine open the DMG in PowerISO and convert to an ISO or ZIP. Extract ZIP/iso with unarchiver. You should be good. Install the app and upload as much data as you can. Then do a reinstall.

    As far as I know, this /should/ work. That or get a random HDD that has a IDE pinout, drop that into the G4 HDD bay, install OSX on that. Run the old drive as a slave and extract the data from it.
     

Share This Page