No "Empty Trash" in Snow Leopard??

Discussion in 'macOS' started by skybolt, Sep 14, 2009.

  1. skybolt macrumors 6502a

    Joined:
    Feb 20, 2005
    Location:
    Nashville, TN, USA
    #1
    Don't really know if this is SL related or not (because I had not looked for this in a long time), but yesterday I decided to empty my trash,since I had been bad and not emptied it in a long time. Shockingly, there was no longer an option in the finder to empty trash. I can secure empty, but with 6,000 items to delete that will take forever. The option for Empty Trash is not just grayed out, it is not there at all! Where did it go, and how do I get it back??

    I have repaired permissions, and restarted, to no avail.

    Thanks for any help!
     
  2. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #2
    Doesn't look like this for you? *edit without secure empty?* It's only appeared secure when held the cmd key for the screenshot*
     

    Attached Files:

  3. stridemat Moderator

    stridemat

    Staff Member

    Joined:
    Apr 2, 2008
    Location:
    UK
    #3
    It is only grey out on mine when nothing is actually in the trash. hmmmm interesting!
     
  4. bigjnyc macrumors 601

    bigjnyc

    Joined:
    Apr 10, 2008
    #4
    what happens if you remove the Secured empty option from finder preferences?
     
  5. iPhone 62S macrumors 6502a

    iPhone 62S

    Joined:
    Aug 18, 2009
    #5
    Click the finder icon in the Dock then hit "Help" on the toolbar and type "empty", see if anything comes up for you.
     
  6. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #6
    Finder -> Preferences -> Advanced -> Uncheck "Empty trash safely"
     
  7. skybolt thread starter macrumors 6502a

    Joined:
    Feb 20, 2005
    Location:
    Nashville, TN, USA
    #7
    Hellhammer had it right! It was simply a matter of going to Preferences and unchecking the box for "Secure Empty". "Empty" showed up after unchecking that box. Apparently on some installations of SL, the preference is defaulted to Secure Empty, and you have to manually go in and change it. I say "some" because my husband had installed SL and did not have the same behavior I had. That is why I thought it was some other issue.

    Thanks for the help!
     

Share This Page