No Entry screen after Kodi addon!

Discussion in 'OS X Yosemite (10.10)' started by sevenhells, Dec 13, 2015.

  1. sevenhells macrumors newbie

    Joined:
    Dec 13, 2015
    #1
    Hello,

    After I installed and rebooted, I get no entry sign with sensor sign:



    Specs: mid 2013 macbook pro
    OS: Yosemite
    Drive: Samsung 850 pro 265gb

    I've tried both El Capitan and Yosemite with this ssd and it's been acting weird, lots of PRAM and SMC boots, yosemite works better in the end. I downloaded chameleon and enabled TRIM since this SSD is third party, this seemed to fix things.

    I'm still able to hold the "option" key and repair my SSD drive, but that's about it.

    Do I have to install Yosemite from a flash drive again?

    Thanks!
     
  2. sevenhells thread starter macrumors newbie

    Joined:
    Dec 13, 2015
    #2
    Why did I even sign up and post in this ghost-town
     
  3. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #3
    You do need to be a little patient, eh?
    (I think you probably signed up on this "ghost-town", probably looking for help. Unfortunately, no one knew ahead of time that you would be here to ask a question. So, you get to wait a bit until the next poor soul is free to help. That would start with me, I guess, so here goes... :D )
    If the Kodi add-on installed some kext in your system, it might not be compatible - and would certainly mess with El Capitan, unless you also disabled SIP before you tried to install it. If you needed to enter your admin password when you installed the add-on, then it's likely that some kext was either added, or replaced another kext. Could be something that is simply needs to be updated for newer OS X versions.

    The result is often the "prohibited" symbol.
    The fix, is to reinstall OS X.
    And, contact the site where you downloaded that Kodi addon - they may have a patch to get that to work now.

    Booting with the Option key just shows the boot selector screen, and doesn't give you the opportunity to repair anything.
    I am guessing that you booted with Command-R, which boots to the Recovery system. That has Disk Utility, and a couple of other utilities. That only will tell you that the file system, and hard drive appear to check OK. But, doesn't fix the boot software on your drive.
    Again, you would reinstall OS X to fix your kext issue.
     
  4. sevenhells thread starter macrumors newbie

    Joined:
    Dec 13, 2015
    #4
    Thanks! reinstalling OS is what I did, but I didn't fresh install, just installed Yosemite over my current Yosemite since it was freshly installed only hours before. Didn't have to install anything over again like Word, CS, etc. I also installed "Chameleon SSD optimizer" and enabled trim since this is a third party SSD.

    I'm still getting hanging on restarts sometimes, ever since got the SSD actually. SMC reset and PRAM is on the daily. However, I did drop and smash this laptop screen recently, so it may be the motherboard. I reformatted my old HDD and that was also working terribly, so I think it rules out SSD compatibility.

    Is there a way to check if my motherboard is faulty without bringing it in?

    Thanks!
     
  5. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #5
    You can boot to the built-in Diagnostics.
    You said that you have a "Mid-2013 MacBook Pro", but I don't know which one that is.
    There is only the Early 2013, or the Late 2013 models
    If yours is an Early 2013, then instead of Diagnostics, you would run the Apple Hardware Test.

    The procedure is the same. Just restart, while holding the D key, until you see the test starting up. Run the test. If it generates error codes, you can come back here. Someone will know what that means.

    There's absolutely no reason that you should need to do both an SMC and PRAM resets every day.
    Don't forget that the PRAM reset also resets the startup disk selection, so be sure to select your SSD in the pref pane. Otherwise, it can take longer to boot when your system boot disk is not selected in that pref pane. That might even fix the occasional hang on restart.
    The TRIM enabled (or not enabled) is not really relevant, except over the life of the SSD, and would not be contributing to hanging during boot.
     

Share This Page