No external apps start in iPod Touch 2G

Discussion in 'iPod touch' started by namru, Dec 9, 2008.

  1. namru macrumors newbie

    Joined:
    Dec 4, 2008
    #1
    Hi, I have used my iPod Touch 2G for about a month and had this strange behavior twice. Only the apps that came pre-installed can be started (mail, safari...) but none of the purchased or free apps can. They start to display the app but quit in about a second.

    Restarting didn't do anything but then I downloaded a free app from appstore to test it and suddenly all apps worked again! this happened one more after a few days which could be fixed by downloading another app.

    I was wondering if anyone noticed this kind of behavior on their 2G iPod Touch?
     
  2. ThunderBull4 macrumors 6502

    Joined:
    Jul 28, 2008
    #2
    I've noticed this before when I had 2.0 Jailbroken. All my apps were crashing except for the standard apps. I ended up rejailbreaking anyway because 2.1 had come out, then that had solved everything. You said you resetted it, but what about a restore? You won't lose your apps or music as long as its backed up (which iTunes does)
     
  3. namru thread starter macrumors newbie

    Joined:
    Dec 4, 2008
    #3
    Thanks for the tip, I'll try a restore if it happens next time. I've only resetted it. It began after updating to 2.2 and it has not been jailbroken so it can't be that.
     

Share This Page