"No firewire ports found"...

Discussion in 'MacBook Pro' started by Fishrrman, Jan 27, 2012.

  1. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #1
    I bought a MacBook Pro 13" back in April 2010, and it's been a great computer, except for one problem: firewire.

    Actually, after I bought it, I didn't use the firewire 800 port much (at all?) until March, 2011. When I tried plugging in a firewire device (audio interface or hard drive) it wasn't seen by the Mac. It didn't show up in Disk Utility. Finally, I checked Apple System Profiler, and when I clicked on "Firewire", I got the message, "no firewire ports found". Neither a PRAM reset or an SMC reset would bring them back to life.

    I brought it to the local Genius Bar (with only about three weeks left of the warranty), and after some testing, they replaced the logic board the same day. Oddly enough, it _still_ wouldn't recognize the presence of a firewire port until I replaced the existing system software with a backup I kept around. Finally, it seemed healthy again, reporting that the firewire ports were indeed "there".

    Since then, I never really used the firewire until today. And....

    Again.... tried plugging in a firewire 800 hard drive, and nothing.
    Went to Disk Utility, the drive isn't there.
    And finally, checked System Profiler, and.... "no firewire ports found".

    The "usual fixes" won't work (PRAM and/or SMC reset).

    I recall from years back when firewire was newer, that some folks had luck "reviving" dead firewire ports on a Mac by removing it from power, pulling the PRAM battery, pulling the RAM, and letting it sit "completely dead" for a while. And sometimes, that worked.

    I did a little googling and read something about how the firewire ports are protected by some kind of "overload protection circuit" that disconnects them if a problem is detected. There isn't really a "software-controllable reset" for this -- instead, the overload protection _automatically resets_ after all power is removed. This would seem to explain how the firewire was "revived" on older Macs, as noted in the preceding paragraph.

    I'm wondering if the same trick would work on a recent MacBook Pro? Anyone ever tried it? As mine wasn't designed with a "user-removable" battery, guess some considerable disassembly would be involved. I can see removing the battery and the RAM as well. Do MacBooks have any kind of a "PRAM battery" inside, as well?

    Going back to the Genius Bar again tomorrow to get it looked at, perhaps tested with whatever software they have available that I don't have. I'm just looking for "an easy fix" -- I don't absolutely need the firewire capabilities, so it's not worth paying for a motherboard replacement.

    Not sure if they'll be willing to help, but I'll ask the genius/tech if he would mind opening the thing, pulling the RAM and battery, and then closing it back up, to see if that works...

    Speculation on my part:
    I'm wondering if the act of simply plugging in a firewire 800 cable -- whether there is a problem with the device that's being connected or not -- is enough to "trip" the overload protection circuit? And thus "cutting off" the firewire ports from the motherboard, and thus (since they are disconnected) when System Profiler is launched, and checks around to assemble its hardware report, can't "find them", producing the "no firewire ports found" message?
     
  2. Fishrrman thread starter macrumors G3

    Joined:
    Feb 20, 2009
    #2
    Took the MBPro to the local Genius Bar, and the techie took off the back and disconnected the battery for a few moments (on this particular model, the battery connection can be disconnected without removing the battery itself).

    Put it back together, and still.... "no firewire ports found".

    I'm surprised no one else commented...
     
  3. IanJF macrumors newbie

    Joined:
    Apr 10, 2012
    #3
    Hi,

    Yes I believe I have the same problem. I have a 2010 27" iMAC. Never used the FW800 port until I purchased a Mercury Elite Pro external drive. Plugged the FW800 cable in and nothing!!!

    I tried everything I could think of including the usual procedures - even spoke on the phone with Apple and nothing. This iMAC I did rebuild at one stage. So not sure if the FW800 ever worked????

    They want me to bring it to a repair shop now, but they said it could be gone for up to a week and that is too long to be without my MAC :(

    Just wondering if anyone has found a solution for this problem at all????
    I'm half tempted to just live with USB functionality, but I did pay for the expensive drive with FW800 on it....

    Like your situation, my FW port doesn't show up, and the drive doesn't appear in the software either. The drive works fine on another iMac using the FW800 port.

    Wish these FW ports were less problematic than they are, I too think its something to do with that overdrive protection or whatever it is!?!?

    Thanks,
    Ian.
     
  4. Fishrrman thread starter macrumors G3

    Joined:
    Feb 20, 2009
    #4
    This is a revival of an old thread I started, but I have an update….

    Since the original post, I presumed the firewire ports on this MacBook Pro were "dead and gone" without a motherboard replacement, and the computer was out-of-warranty.

    For that reason, I didn't expect to use Firewire with it again.

    This morning, tried installing Mountain Lion Developer Preview 4 onto an external drive connected to the MBPro via USB. Got the installation done, and thought I'd check System Profiler. To my amazement, I did not get the "firewire ports not found" message (as in my original post above). Instead, got "Maximum Speed: Up to 800 Mb/sec".

    A few minutes ago, shut the power down, and connected via a firewire 800 cable to my Other World Computing "Voyager" USB/SATA/firewire docking station. The MBPro now "sees" the dock via firewire and boots from it -- after firewire had been "unseen" and unusable for more than a year!

    So, apparently firewire can be "revived" after having "gone dead".

    This was not a "port management reset", or any other reset that I as a user performed. All I did was run a standard Mountain Lion installation.

    I'm going to take a -guess- that during the installation something gets reset or updated, possibly in the firmware or in the "EFI" area. My knowledge is limited in that area, can't speculate beyond that.

    Happy to have my firewire back!
     

Share This Page