No firmware update for Sony DRX-810UL-T??

Discussion in 'Mac Accessories' started by maya1, Dec 31, 2005.

  1. maya1 macrumors newbie

    Dec 31, 2005
    Yesterday I bought a Sony DRX-810UL-T DVD/CD Rewritable Drive. I tried to burn CD but the burner hanged half way thru. I have Toast 6.0.9. I tried different speed, 2X, 4x, 10x, up to 40X, and got the same result. I tried with Mac burner included in OS 10.X; got the same result.

    Sony website offers a firmware update for Windows but not for Mac.

    The DRX-810UL-T is supposed to be Mac compatible???

    Can someone help me...

  2. iMeowbot macrumors G3


    Aug 30, 2003
    Sony claim that the drive should be compatible with 10.2 or later.

    Where did you find that firmware update so we can have a look? It may be possible to extract the firmware from the Windows installer and use a Mac program to do the update.

    [Edit: Okay, it turns out that the drive inside that Sony case is a BenQ DW1640. It's a well regarded drive in the PC world, but I notice that the original BenQ version and the Plextor PX-740A (these are all really the same drive as the Sony) only claim Windows support.

    You may be better off exchanging the drive (I hope its new and you can do that) for something with a Pioneer or Matsushita/Panasonic/National drive inside, those two tend to be very well supported in the Mac world.
  3. maya1 thread starter macrumors newbie

    Dec 31, 2005
    Sony read my complaint. Two days ago, we can download the new firmware which is now available for Mac. My drive is working perfectly. Now I can burn CDs and DVDs. Thanks Sony.
  4. Gokhan macrumors 6502a

    Oct 7, 2003
  5. bitspersecond macrumors newbie

    Feb 12, 2010
    Found the location of the firmware update. Posting it here for posterity:

    Of course, it didn't work for me... (it always says 'This drive is now allowed to be updated'). Not sure if it's because I have a DRX-810UL (not a DRX-810UL-T), or because my firmware says it's 2.0b and the documentation that comes with the updater says it updates to 3.0f and that's just a leap too far? Arrrghh.... so close.
  6. obsolescence macrumors newbie

    Feb 24, 2010
    Is anybody able to get this drive working in Snow Leopard? It shows up in the system profiler but any discs that are inserted are not mounted, etc. I'm just wondering if the drive is incompatible with 10.6 or if my particular unit is defective.

Share This Page