No GUI after login

Discussion in 'Mac Basics and Help' started by Chessman.exe, Jan 13, 2012.

  1. Chessman.exe macrumors newbie

    Joined:
    Jan 13, 2012
    #1
    I just acquired a macbook pro, with Snow leopard. I just went to share some files and must have accidentally made it so everyone had 777 permission (to read / write everything). Ooops! This messed everything up, so I went and I chmod 644'd everything in /System/Library/LaunchDaemons and I made it to the actual login screen.
    After logging in, I get a gray screen, no text, and at one time I had a terminal, but am not sure that is still there and will stay there if I restart. What happened and what can I do? I'm good with linux, but i've never had this problem with a mac.
    I even tried to bypass the login with the rm /var/db/.applesetupdone

    So as it stands now, I can see the apple, and the scrolling wheel when it starts up, and hangs. it says AirPort: RSN handshake complete on en1 in verbose mode.

    I'd imagine the equivilent for windows is when explorer.exe does not execute and you have to redo.

    But when I insert the cd, it beeps 3 times again and again and does not proceed to any sort of failsafe.
    Ideas? Thanks in advance!
     
  2. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #2
    If you really and truly chmod'ed everything to 644, you've probably borked the system's launch daemons at a minimum). And since almost everything interesting is a result of system launch daemons (specifically, launchd running as root is the init process), you've probably borked the system startup procedure, and the login procedure (which needs to run as setuid, which is directly in conflict with 644 mode).

    You might possibly be able to fix it by using Repair Permissions, if you can boot from another drive or DVD or CD. Otherwise my first guess would be that you've damaged the system beyond repair and should reinstall from the original DVD or CD.


    I don't know what you mean by "insert the CD". Do you mean the original OS Install CD? Or DVD (if it's really a DVD)?

    Exactly where and when do the 3 beeps come from? During startup? Some other time?

    You need to list the exact steps you're doing, and exactly what you're doing them with. Like whether it's an install CD/DVD, what OS version it is, whether it's a gray model-specific disc or a general retail disc.
     
  3. Chessman.exe, Jan 14, 2012
    Last edited: Jan 14, 2012

    Chessman.exe thread starter macrumors newbie

    Joined:
    Jan 13, 2012
    #3
    I mean the actual installation DVD, when I insert it and start up, the apple pops up and it beeps 3 times continuously.
    This is snow leopard, so 10.6.
    Thanks for the quick reply! Let me know if you needed more info.

    If there is a combination of keys I can hold down to get me to the disk utility screen or repair permissions screen, that would supposedly be all I need.

    EDIT: I guess I'm just smart, or really dumb. I went to the command + s mode when mac starts and did "chmod -R 755 /System" and immediately said "aw crap" because I could have bricked the system. But, as it turns out, it fixed the system. Still not sure how, but it seems to be better now. THanks a lot!
     
  4. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #4
    10.6.what?

    To bring up the Select A Boot Disk screen, hold down option (or ALT) key after you hear the startup chime.


    755 might work better than 644, but it's still wrong. Some things might malfunction. Security might be compromised (if I were placing a bet, I'd bet it is compromised). Can't really tell what all the consequences are, but it's definitely wrong.

    You should find out why your DVD won't boot. Is it gray (the actual color of the top of the DVD)? That's the color of the DVDs shipped with Macs. They are model-specific, but should always work if they match the computer. If not, then you won't get it to work, and you should contact Apple support for how to obtain a DVD that works with your Mac model.

    If the DVD is a retail version, it won't be painted gray. It would probably be white with a picture of a snow leopard on it. AFAIK, all the retail DVDs have that illustration on them. No retail OS DVD I'm aware of was ever gray. Black (Leopard and earlier), white, other colors, etc. Never just gray.


    You might not be able to run Repair Permissions with the OS booted from the "borked" disk. It's worth a try. If it works, great. If not, oh well. If it complains about not fixing things, which is a good possibility if security was compromised (setuid bit removed), then you're safer reinstalling the OS. But see here first:
    http://forums.macrumors.com/showthread.php?t=404695


    For future reference, the Mac OS X kernel and system is completely different from Linux, so don't think that knowing how to boot or build Linux systems is transferable knowledge. The only thing I'd say they have in common is that chmod -R xxx / while running as root is equally dangerous.
     

Share This Page