No HiDPI/4K Option (2014)

Discussion in 'Mac mini' started by ThisIsNotMe, Oct 29, 2014.

  1. ThisIsNotMe macrumors 68000

    Joined:
    Aug 11, 2008
    #1
    Trying to figure out how to enable HiDPI on a new (2014) MacMini hooked up to a 4K display (Sony TV) through a Marantz receiver.

    I can easily get 3840x2160 to display but it does not offer the same usability as say my rMBP.

    Am I just an idiot or is there something that I need to do to enable HiDPI?

    Thank you.
     
  2. stevemr123 macrumors member

    Joined:
    May 27, 2010
    #2
    The mini does not provide the usual settings found on Retina MBPs. You should simply choose the 1920x1080 scaled resolution. If you don't see a "(low resolution)" remark next to it, then it will be HiDPI.
     

    Attached Files:

  3. ThisIsNotMe thread starter macrumors 68000

    Joined:
    Aug 11, 2008
    #3
    When I select 1080p@60 the output is 1080 not 4k with a scaled UI.
    What am I missing?
    Makes 4K fairly pointless on the MacMini (and makes my new MacMini an expensive paperweight)
     
  4. ElectronGuru macrumors 65816

    Joined:
    Sep 5, 2013
    Location:
    Oregon, USA
    #4
    It's like with trim. Apple doesn't enable HiDPI on models that didn't come with retina HW. Download display menu from the App Store, it can see the hidden modes.
     
  5. stevemr123, Oct 31, 2014
    Last edited: Oct 31, 2014

    stevemr123 macrumors member

    Joined:
    May 27, 2010
    #5
    You should try enabling HiDPI mode using Quartz debug (or terminal). Also, if you hold the Option (Alt) key while clicking on "Scaled" in System Preferenes/Displays, you'll see the list of all possible resolutions, not only the select few that OS X thinks are the best options for you.

    But 4K won't work at 60Hz with Intel Iris, only at 30Hz by default, with manual timings you can get 50Hz.
     

Share This Page