no iCloud on old iMac since august????

Discussion in 'iMac' started by keepingup, Feb 12, 2015.

  1. keepingup macrumors member

    Joined:
    Jan 14, 2011
    #1
    I noticed that my photos were syncing perfectly between my macbook air, iPhone 6, and iPad. But my office iMac (20", late 2006) is not up to date. I tried to click on iCloud on the iMac. The message says "Loading iCloud", but the colored wheel just turns and turns without loading it. I did a restart but got the same result.

    Possibly can anyone tell me what to do next? Thanks in advance.
     
  2. keepingup thread starter macrumors member

    Joined:
    Jan 14, 2011
    #2
    more info...

    System preferences did finally show my iMac iCloud settings. The iPhoto sharing button would not click. Apparently my OSX is too old, 10.7, one needs 10.9 or later. I tried to update iPhoto and buy 9.5 but it says my system is too old.

    I am afraid to install mavericks because when I did so on an old ibook (which I loved!) the computer slowed to a crawl and could not be fixed. Had to toss it and buy a macbook air. And you prob. know that one cannot uninstall an operating system. So I am afraid to corrupt my trusty office computer by trying to upgrade. [there are 360 gbs available though; perhaps i should risk it????]

    Guess I'm stuck unless one of you brilliant youngsters has knowledge!
    How I love playing the old lady card…heh heh heh
     
  3. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #3
    You couldn't go beyond Lion even if you wanted to.

    Only mid-07 and later can run Yosemite.
     

Share This Page