No iMessage phone number...Help?

Discussion in 'iOS 5 and earlier' started by iVerne, Oct 27, 2011.

  1. iVerne macrumors newbie

    Joined:
    May 11, 2011
    #1
    Hi:

    Ive noticed that my iPhone's phone number is not associated with my iMessage account. My contacts are only able to iMessage me with via my email address. I still receive normal sms messages via my phone number. I checked my settings:

    Settings/Messages/Receive At/No Phone number associated with the account.

    I also can't find a way to "add" my phone number. Anyone experience this or have a fix for this?

    Thanks!
    Verne
     
  2. P.K. macrumors newbie

    Joined:
    Apr 29, 2011
    Location:
    Ireland
    #2
    Settings > Phone > My number

    Make sure your number is defined here, including international dialling code, then try activating iMessage again.
     

Share This Page