No indicator light-whistling sound from Apple Extreme.

Discussion in 'Mac Accessories' started by Tenashus1, May 8, 2013.

  1. Tenashus1, May 8, 2013
    Last edited: May 8, 2013

    Tenashus1 macrumors 6502

    Joined:
    Jul 27, 2011
    #1
    All of a sudden I come home from work, and boom, no light on the Extreme, and a whistling sound from the power cord to the router. Went to the Apple store. Checked the wires and, indeed, it was a router malfunction. Bought a new one. Wish I knew what happened to the old one. Had it for less than 2 years. Never had an Apple product crap out on me since my Apple IIe had to have a motherboard replaced (1984, I think). A little disappointing.
     
  2. COrocket macrumors 6502

    Joined:
    Dec 9, 2012
    #2
    If I ever get a 30 year stretch without my computer/accessories crapping out I'll be pretty stoked!
     
  3. FreakinEurekan macrumors 68040

    FreakinEurekan

    Joined:
    Sep 8, 2011
    Location:
    Eureka Springs, Arkansas
    #3
    Hard to say. Do you have your power plugged into a conditioner or UPS? No guarantee that will prevent failures of course, but it helps.

    Also if you have AppleCare Protection Plan on your Mac, and your router was purchased up to two years before the Mac or during the AppleCare plan coverage period, then AppleCare covers the router too! Good for AirPort and time Capsule products.

    http://www.apple.com/support/products/mac.html

    Footnote 2: "The AirPort device or Time Capsule must be purchased up to two years before your Mac purchase or during the term of your AppleCare Protection Plan coverage."
     

Share This Page