No Internet connection waking from sleep

Discussion in 'OS X El Capitan (10.11)' started by Imsuperjp, Mar 4, 2016.

  1. Imsuperjp macrumors 6502

    Joined:
    Apr 9, 2010
    #1
    I bought a brand new macbook retina. I don't know if this is a hardware issue or a OS issue. When my macbook wakes from sleep, the wifi connection shows connected with IP address but it will not load any internet sites. I have to turn the wifi off and back on to get the webpages to start loading. I've did some research and redid the network preference and configuration files with no luck. My macbook air I sold before I bought the Macbook had no issues as well as all my other devices. I set the macbook as a new laptop and did not restore from backup. Is any one having this issue and what did you do to fix it?
     
  2. iLG macrumors member

    Joined:
    Sep 30, 2011
    #2
    If it's brand new I'd be contacting Apple for help
     
  3. dubstar82 macrumors newbie

    Joined:
    Nov 4, 2013
    Location:
    Los Angeles CA
    #3
    I'm having the same issue with my new MacBook as well. Haven't found a solution yet.
     
  4. CTHarrryH macrumors 65816

    Joined:
    Jul 4, 2012
    #4
    I had that issue a while ago - can't unfortunately, remember exactly what I did but I know I played with some of the sleep and network issues and it got fixed. I'd play with settings
     
  5. -BigMac- macrumors 6502a

    -BigMac-

    Joined:
    Apr 15, 2011
    #5
    I have found this too on occasion.

    iMac 2015 5k 27"
    Using 5g Wi-Fi
     
  6. niji macrumors 6502a

    niji

    Joined:
    Feb 9, 2003
    Location:
    tokyo
    #6
    if you many WiFi networks remembered, then drag the ones you most frequently to the top of the joined WiFi list
    the other good thing is to learn how to use Locations. Set a Location first. The Location is never changed automatically.
    You can control WiFi as 1 location. LAN as a separate Location.
    What this amounts to is telling your system in advance to look for and use only pre-set connections for that location.

    You can allow your system to sleep (display).
    But you might also want to prevent the computer from powering down, which is found in Energy Saving.
     

Share This Page