No Internet Connectivity

Discussion in 'macOS' started by me43, May 31, 2017.

  1. me43 macrumors member

    Joined:
    May 11, 2011
    #1
    Hello all,

    Several days ago my mac (Early 2013 MacBook Pro 15") updated automatically to 10.12.5 overnight and has not been able to access the internet since. The wifi bars show full strength but the computer is not able to use anything it picks up. I have tried using my phone as both a wifi hotspot and connected directly to my computer with no luck. I have tried all kinds of things including updating to the most recent beta (which I then reverted from) but nothing has fixed the problem. Unfortunately I had not been able to backup the last couple of weeks so reverting to a previous backup wouldn't be a preferred option.

    The one interesting thing I have found is the internet works as it should when the computer is in safe mode. I'm sure this has some significance but I don't know what it means myself.

    If anyone has an ideas or has had a similar experience guidance on what to do next would be greatly appreciated.
     
  2. cobracnvt macrumors member

    cobracnvt

    Joined:
    Apr 6, 2017
    #3
    First step is to confirm what your TCP/IP settings are and make sure they are correct for your network. You can quickly see what your current settings are by holding the "option" key and clicking on the wi-fi symbol at the top of your screen.

    Are you getting assigned an IP address and a router IP address?
     
  3. Yahooligan macrumors 6502a

    Yahooligan

    Joined:
    Aug 7, 2011
    Location:
    Illinois
    #4
    OMG, option-click on menu icons...how did I not know about this before?! This is awesome.
     
  4. me43 thread starter macrumors member

    Joined:
    May 11, 2011
    #5
    I tried the SMC and NVRAM resets and I checked the TCP/IP settings with another mac on the network. Unfortunately neither of these solved my problem but thank you for the replies.

    I ended up just starting with a fresh copy of macOS sierra and using my backup to restore my documents. The first time I tried with both applications and documents but that didn't solve my problem so it was obviously an application that was causing the problem.

    So now back to re-downloading all of my applications...
     
  5. cobracnvt macrumors member

    cobracnvt

    Joined:
    Apr 6, 2017
    #6
    Have you tried taking your laptop to another location with a totally different wifi network to test internet access?
     
  6. me43 thread starter macrumors member

    Joined:
    May 11, 2011
    #7
    I didn't try a different location but I did create a wifi hotspot with my phone as well as hardwiring it with my lightning cable.
     
  7. cobracnvt macrumors member

    cobracnvt

    Joined:
    Apr 6, 2017
    #8
    I would try a totally different wifi if it's possible. Just to rule out your environment and avoid a total reinstall of your OS.

    Some tests from Terminal:

    1. try pinging an external IP address, for example: ping 4.2.2.2
    2. try pinging an external IP address by host name, for example: ping www.apple.com
    3. try pinging your routers internal IP address. This is specific to your network, but it's probably something like: ping 192.168.1.1

    (press control-c to break out of the ping)

    When you do the pings above, do you get any replies?
     

Share This Page