No internet on 3G/Edge after upgrade to iOS4

Discussion in 'iPhone' started by spectre51, Jun 21, 2010.

  1. spectre51 macrumors 6502

    spectre51

    Joined:
    Feb 25, 2008
    #1
    Seems like quite a few people are seeing this issue over at the Apple support forums. I had it happen to my 3GS but not my wife's. After the upgrade which went smoothly I could get no internet via 3G or Edge only via WiFi. I checked all the settings to make sure 3g data was on and even tried turning it off then back on but nothing. I did a restore to factory and then restored from a backup but same issue. The final thing I tried was a fresh restore and didn't restore from a backup but left everything stock and that worked. I am currently reinstalling all my apps and re-setting up the phone.

    Just an FYI for anyone else that runs into this issue, restore to fresh phone and do not restore from a backup but re-setup everything instead.
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
  3. spectre51 thread starter macrumors 6502

    spectre51

    Joined:
    Feb 25, 2008
    #3
    Completely forgot about that option....doh...not gonna restore from a backup to try it though. Maybe that will work maybe not. I will post that at the apple forums and see what happens with one of them.
     
  4. draz macrumors 6502a

    Joined:
    Jun 20, 2010
    #4
    Once you set up as a new phone try to restore from a backup and see if all your stuff comes back as well as keeping your MMS, Data, and whatever else was missing.

    actually nvm you tried that....
     
  5. Loves2spoon macrumors 65816

    Loves2spoon

    Joined:
    Jun 3, 2010
    Location:
    California
    #5
    Had the same problem, just turned airplane mode on/off over and over until I got a signal. Works now.
     
  6. spectre51 thread starter macrumors 6502

    spectre51

    Joined:
    Feb 25, 2008
    #6
    I tried the airplane mode too but that didn't fix it.
     
  7. spectre51 thread starter macrumors 6502

    spectre51

    Joined:
    Feb 25, 2008
    #7
    Nope that didn't fix it. Just restored from backup and had the issue. Reset network settings and still nope. So far only doing the fresh restore and setting up as a new phone seems to work.
     
  8. teng106 macrumors newbie

    Joined:
    Jul 7, 2010
    #8
    jailbroken 3gs new bootroom upgrade to vanilla ios4 wifi not working

    Hi,
    I have spent a whole day searching posts for any solution regarding my issue.
    So here's what happened:
    I recently had a blackra1n jailbroken iphone 3gs 3.1.2 new bootrom (tethered) and unlocked with snow. i had troubles with WIFI so i reset network settings and ofcourse, since it's tethered, i had to connect to itunes. Then, my iphone did not reboot anymore. so i decided to upgrade to ios4 with plans to have it on a vanilla ios4. Everything went fine, restored from back up but had the following issues:
    1. My signal name and status bar is still personalized and has my name since i had MIM.
    2. This is what i am more concerned, i can't connect to WIFI. Tried resetting network settings, tried airplane mode, tried on and off wifi, still, to no avail.

    Please help. I would really love to have my wifi working regardless if it's a jailbroken iphone or not. I plan to keep it at ios4 since i hated the tethered jailbreak and i am not very knowledgeable with this so i am brushing off the idea of going back to 3.1.2.

    Any help or solution on these will be very much appreciated.

    Thanks!
     

Share This Page