iPad No keyboard input accepted on iPad3 w/ 6.1.2 jailbroken

Discussion in 'Jailbreaks and iOS Hacks' started by darwin022, Nov 22, 2013.

  1. darwin022, Nov 22, 2013
    Last edited: Nov 22, 2013

    darwin022 macrumors regular

    Joined:
    Oct 4, 2005
    Location:
    DC
    #1
    I've had my iPad 3 jailbroken since the 6.1.2 jailbreak was released (a LONG time, can't remember exactly when) with very few issues that couldn't be resolved easily. This week, it finally developed a problem that is quite troublesome:

    From the lock screen, when I try to input the passcode, no characters show up and I can't unlock the device. I've tried with the on screen keyboard (shows up, just doesn't produce characters) and with one of the older hardware keyboard docks. I can't find my USB adapter to try a USB keyboard. Rotating the device doesn't seem to fix it either (That fixed a touch input issue a while back)

    Interestingly, if I try as SOON as the device boots, I can get a few key presses in before it goes wonky. I've tried several times, but can't type the passcode fast enough before it stops responding.

    The obvious fix would be to restore the iPad, but I haven't been able to find a way to bypass Apple's strangle hold and not signing iOS 6.x anymore, even for a device that is currently on it. Restoring from backup also requires the device to be unlocked- and my last backup of the device isn't complete anyway.

    So, does anyone have any thoughts or suggestions? I really don't mind starting fresh, nothing important was stored on the iPad anyway, but I'd really like to keep the jailbreak so don't want to upgrade it to iOS 7 yet. I already have the ipsw's and SHSH Blobs, just no way of restoring them.

    One questionable thing that should NOT be related- if it is, it's very creepy: I upgraded one iPad mini retina to iOS 7.1 beta and enabled the black keyboard. The problem on the iPad 3 developed the next morning. Both devices were signed into the same iCloud account but almost all syncing has been disabled.

    Thanks!

    Edit: powered on the device again just now, and strangely... it worked on the first try. NO indication of why it was having issues or why it mysteriously started working again. So I guess most of this issue is solved. However, I would still like to see if there is a good way to do a restore.
     
  2. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #2
    try booting up while holding the volume up button, this essentially disables all your tweaks. from there, you can uninstall the offending tweak from cydia
     
  3. darwin022 thread starter macrumors regular

    Joined:
    Oct 4, 2005
    Location:
    DC
    #3
    Interesting. Thanks. I'll try that out next time around. It happened again after another reboot, but since I had already disabled the passcode for testing... wasn't a big deal and the keyboard input came back after several minutes.

    Also, I hadn't installed anything new (and no updates) in Cydia for the the last month or two. I'll keep monitoring. The device in question is my primary hotspot since it has unlimited data. I may swap that over to a retina mini, but still like certain tweaks such as netmeter. Dropping 1.5lb from my bag would be nice though.
     

Share This Page