No Login Prompts with iTunes in El Capitan-only?

Discussion in 'OS X El Capitan (10.11)' started by saytheenay, Mar 23, 2016.

  1. saytheenay macrumors member

    Joined:
    Jul 6, 2012
    #1
    I attempted to upgrade (clean install) last year to El Crapistain and iTunes 12.2.3 or higher. However, one major issue held me back: with every version after a clean install, iTunes eventually no longer allows me to do anything where a login prompt is required. I can go to iTunes Store, but if I click on Account or anything else that wants my credentials, no login prompt will come up. As a result, I can signin, authorize or deauthorize my account on the computer, buy anything, etc. As a result of this, I downgraded to 10.10.5 and I don't have any of these iTunes login issues--it is only on iTunes 12.2.3 or higher and El Capistan. I do some mobile development tinkering and now that Xcode 7.3 only works on 10.11.x, I would like to upgrade.

    I have had this problem--and tested it--in each version from 10.11.0 - 10.11.4 and it is still there for me. Typically it works for a while but then, without any software changes, it stops working within a week or two after a clean install.

    Note that I use iTunes for my own local music (no Apple Music service), podcasts, iTunes U and iOS syncing with no iCloud use or backup.

    I have tried quite a few things and none of them have worked--I have tried:
    • Create a new OS account--still can't login to iTunes
    • Delete existing OS account and recreate it--still can't login to iTunes
    • Create a new iTunes account--still can't login to iTunes
    • Delete all iTunes preferences--still can't login to iTunes
    • Delete all Safari preferences, cookies and website data--still can't login to iTunes
    • Logged into iCloud (even though I don't use it for anything on my Mac)--still can't login to iTunes
    iTunes working properly is critical to me--if I can't get it to work, I will stay on Yosemite until my 2013 MBA dies.
     
  2. saytheenay thread starter macrumors member

    Joined:
    Jul 6, 2012
    #2
    Got a new Macbook Air (in case they discontinue them at WWDC 2016). Set it all up with FileVault2, CS6, Office 2011, etc. No issues, however, I did disable System Integrity Protection (SIP). Its running 10.11.5, 8/i7/512.

    Once I everything else set, I started up iTunes 12.4 and tried to Sign In/Authorize. All attempts are STILL failing. No long prompt, no nothing. I was, however, able to installed iTunes 12.4 and log in via a Windows 10 VM running in VirtualBox on the same MBA.

    I have put in a post on Apple's support forums--nothing. I scoured Google and nothing. At this point, I am about ready to give up on Mac. Its a sad day when Windows works better than Mac, and being a Unix/Linux guy, I would rather not switch (again), but it is really starting to look like I don't have a choice here.
     
  3. rshrugged macrumors 6502a

    Joined:
    Oct 11, 2015
    #3
    Did you try this?
    https://support.apple.com/en-us/HT203160
     

Share This Page