No Logitec Control Center for Snow Leopard :(

Discussion in 'MacBook Pro' started by ravensfan55, Aug 31, 2009.

  1. ravensfan55 macrumors 6502

    Joined:
    Mar 16, 2009
    #1
    When I found that clicking the scroll wheel didn't bring up Expose like it used too, I was disappointed. Turns out that the latest Logitech Control Center release earlier this month doesn't support SL.

    Now I have to reach for the F3 key. Bleh. But this gives me a legit reason to go get that wireless Mighty Mouse I've been wanting.... :)
     
  2. Jaimi macrumors regular

    Joined:
    Jul 22, 2009
    #3
    I could never trade my Logitech G5 for the Mighty Mouse. I don't like it because it requires a hard surface - the whole top of the mouse moves, so you can't really click the buttons when the mouse is on a soft surface. The scroll ball is cool though.
    What I did is connect my mighty mouse, set up all the buttons, and then unplugged it and set it aside. The logitech seems to honor the settings for the mighty mouse just fine.
     
  3. After G macrumors 68000

    After G

    Joined:
    Aug 27, 2003
    Location:
    California
    #4
    This saddens me. Well, it's not like my MX518 ever worked with it anyway ... :(
     
  4. J the Ninja macrumors 68000

    Joined:
    Jul 14, 2008
    #5
    Have you tried setting Expose to Button 3?

    Also, look into Steermouse. Unlike LCC, it's not glitchy, and it doesn't completely take over your system the way LCC does. It's worth the $20.
     
  5. michael.lauden macrumors 68020

    michael.lauden

    Joined:
    Dec 25, 2008
    #6
    Q.

    Does SteerMouse support Snow Leopard (Mac OS X 10.6)?

    A.

    The current version of SteerMouse works under Mac OS X 10.6 in 32-bit mode. We are working on an update to support the 64-bit mode. The release for this update is scheduled for September.




    straight from the support page.
     
  6. J the Ninja macrumors 68000

    Joined:
    Jul 14, 2008
    #7
    64bit mode = 64bit kernel. Which doesn't boot by default. And this is one of MANY reasons why. It works fine, I'm using it right now.
     
  7. ki2594 macrumors 6502a

    Joined:
    Apr 12, 2008
    Location:
    Carmel, IN.
    #8
    A snow leopard compatible release is in the works and will be available by the end of the month
     
  8. Ice-Cube macrumors 6502a

    Ice-Cube

    Joined:
    Jul 27, 2006
    Location:
    Somewhere over the rainbow
    #9
    Somehow my MX Revolution is still working and all my mouse button shortcuts are still there after I upgraded to Snow Leopard. No issues for me here.
     
  9. michael.lauden macrumors 68020

    michael.lauden

    Joined:
    Dec 25, 2008
    #11
    yeah it did for me too. except the fact that i can't control expose or spaces and my mouse would just stop working and i'd have to unplug the dongle then plug it right back in for it to start working.

    there are many issues with it, even though it 'works'.

    i have uninstalled it and i am just using keyboard short cuts. not a big deal
     
  10. RKpro macrumors 6502

    Joined:
    Oct 27, 2008
    #12

Share This Page