Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

MacBainNO

macrumors regular
Original poster
Jan 16, 2017
109
78
After the 14.7.1 update I'm not getting mail notifications on the lock screen. Anyone else having this issue?
To be more correct if I tap the iPhone I see the new mail, but the screen won't light up or make a sound when getting new mails.
 
  • Like
Reactions: lia1tan

M3Evo

macrumors newbie
Feb 27, 2021
6
0
Hello,

I believe your issue is related to your notifications preferences for Mail.
To check them out, go to: Settings > Mail > Notifications.
Make sure you have the check mark ticked for Lock Screen, Notification Center, and Banners.
Check if the Sounds option is not set to None.

And that's it, you're good to go!
 

MacBainNO

macrumors regular
Original poster
Jan 16, 2017
109
78
Hello,

I believe your issue is related to your notifications preferences for Mail.
To check them out, go to: Settings > Mail > Notifications.
Make sure you have the check mark ticked for Lock Screen, Notification Center, and Banners.
Check if the Sounds option is not set to None.

And that's it, you're good to go!
I have this set correctly, still not working.
 

M3Evo

macrumors newbie
Feb 27, 2021
6
0
Hmm... I might be missing something.

Perhaps the Ringer sound isn't high enough or the Ringer switch is turned off.

Try to test your Mail notifications. Send a mail to yourself from another device while your iPhone is locked. If you receive notifications the way you like, then you no longer have to worry about the issue.

Otherwise, you might have Do Not Disturb turned on.
 

MacBainNO

macrumors regular
Original poster
Jan 16, 2017
109
78
Hmm... I might be missing something.

Perhaps the Ringer sound isn't high enough or the Ringer switch is turned off.

Try to test your Mail notifications. Send a mail to yourself from another device while your iPhone is locked. If you receive notifications the way you like, then you no longer have to worry about the issue.

Otherwise, you might have Do Not Disturb turned on.
All settings are correct. Worked before upgrading to 14.7.1 ,so this update must have broken something.
 
  • Like
Reactions: lia1tan

M3Evo

macrumors newbie
Feb 27, 2021
6
0
I see... Let's run a bit more testing before proceeding to reset Mail preferences.

Have you checked if Background App Refresh is activated for Mail? Or if you have Push enabled for Fetch New Data? Or if you have accidentally muted any email threads?

Eventually, try removing your Mail account then signing back in.

If the above doesn't work, I suggest deleting then reinstalling the Mail app.
 

lia1tan

macrumors newbie
Aug 4, 2021
11
3
United States
All settings are correct. Worked before upgrading to 14.7.1 ,so this update must have broken something.
Everything was working well for me before 14.7.1 too and similarly I don’t get notifications anymore but it is mainly from messaging apps (first and third party) and only occasionally emails. This update definitely broke something.
 

MacBainNO

macrumors regular
Original poster
Jan 16, 2017
109
78
I found a temporary fix. Turn off Bluetooth and it works. So definitely a huge bug.
EDIT: Noticed that it worked with Bluetooth on when I turned my Apple Watch off.
 
Last edited:

Psychbum

macrumors regular
Sep 18, 2012
222
50
I am getting exactly this issue, I had to ditch my Apple Watch for now just to be sure I receive notifications. However, they still come through to iPhone 11 Pro as they wish not reliably! - Needs to be fixed quick time.
 
  • Like
Reactions: lia1tan

Psychbum

macrumors regular
Sep 18, 2012
222
50
Hello,

I believe your issue is related to your notifications preferences for Mail.
To check them out, go to: Settings > Mail > Notifications.
Make sure you have the check mark ticked for Lock Screen, Notification Center, and Banners.
Check if the Sounds option is not set to None.

And that's it, you're good to go!
I observed that after the update these settings had reset to unticked for all the above...

After following all of your steps I am someway to getting a workaround but can't use Apple Watch at all.

Very sloppy update.
 

Marli

macrumors 6502
Apr 9, 2011
382
272
I noticed that I has no notification sounds. I then went into the apple Watch app, toggles the settings and they started to work again (on the watch). Turn off the watch and they work again on the phone.
 

cynics

macrumors G4
Jan 8, 2012
11,959
2,155
I found a temporary fix. Turn off Bluetooth and it works. So definitely a huge bug.
EDIT: Noticed that it worked with Bluetooth on when I turned my Apple Watch off.
If you are wearing your Watch and notifications are mirroring your iPhone and on then you will get the notification on you Watch and your iPhone should not make a sound, the notification will sit on the lock screen until you look at them on it or another device.

Guess it wasn't a bug on the iPhone after all. You're Watch might be broken though if its not notifying you.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.