No message alert (sound/vibration) when locked

Discussion in 'iOS 10' started by Vermifuge, Oct 15, 2016.

  1. Vermifuge macrumors 6502a

    Vermifuge

    Joined:
    Mar 7, 2009
    #1
    My iPhone 6 Plus Running iOS 10.0.2 does not give an audible (or vibration) alert for new messages when locked. This is a standard Apple iPhone 6 Plus. I'm not running any jail broken software.

    The Problem:

    When I receive a text / iMessage AND the screen is locked I do not get an audible or silent (vibration) alert. This just stated happening as I was receiving alerts yesterday. I DO get sounds and vibration notifications if the phone is unlocked when the message arrives. The visual notification DOES appear on the lock screen when I wake the phone up. It also appears if the lock screen is awake but not unlocked (but without sound or vibration.) I have also tried rebooting and turning off various other settings... I DO get alerts on my Mac & Apple Watch...

    Settings > Sounds :
    • Vibrate on ring and Vibrate on Silent are both on (green)
    • Ringer is set to max and "Change with buttons" is off (gray)
    • The text tone is set to Classic Noir and vibration is set to heart beat.
    I have tried different audible and vibration alerts. It does not fix the problem

    Settings > Notifications > Messages :
    • Allow Notifications is on (Green)
    • Show in notification center is on (Green)
    • Badge App Icon is on (Green)
    • Show in lock screen is on (Green)
    • Sounds is set to Noir / Vibration Heart beat
    DND :

    Do not disturb is off (gray)

    Hard Witch / Silent Mode :

    I typically keep the switch in the off (silent / Orange) position. However in my testing I tired it enabled and disabled. It does not make a difference i do not get any sort of alert if the screen is locked.

    Again I have tried a various combination of enabling these and disabling these with no change.
    Yes, I have already verified DND is OFF. It is typically set to automatically enable DND mode at 11:00 PM and disable it around 8:00 AM... Unless I am already awake and I disable it manually.

    Also as a side note, in silent mode (Orange) I do not get any vibration alerts. In normal operation (with audio) I do not get either alert assuming the screen is still locked. The only notification I get is a banner that appears when I activate the screen.
     
  2. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #2
    Is it just messages or other alerts too? Is it for all messages? Could you have DND enabled for some conversations in messages (as those have separate individual DND settings)?
     
  3. Vermifuge thread starter macrumors 6502a

    Vermifuge

    Joined:
    Mar 7, 2009
    #3
    All conversations. Alerts and fine for email, line and hellotalk. I checked the conversations in messages and DND is not enabled on any of my conversations.
     
  4. Vermifuge thread starter macrumors 6502a

    Vermifuge

    Joined:
    Mar 7, 2009
    #4
    Apple Discussion Thread

    As recommended in the thread above, after disabling my bluetooth 9on my rMBP I started to receive notifications again. I did not perform a factory reset & restore. Disabling bluetooth on my rMBP was all that was required.

    That said, I believe the following information to be important. I have a 2015 15" rMBP running macOS Sierra and an Apple Watch Original (SS) Running watchOS 3. I use 2FA to unlock my MBP. Obviously thanks to coherence all of my Apple devices talk to each other.

    This is NOT a solution and I have just traded one problem for another. I need bluetooth (on all of my devices) enabled for a number of reasons on a daily basis.
     

Share This Page