No MMS or 3G (data) after redsn0w JB on 3G iPhone

Discussion in 'Jailbreaks and iOS Hacks' started by Wubby, Jun 25, 2010.

  1. Wubby macrumors newbie

    Jun 21, 2010
    I messed around with this all day on my 8Gb 3G (on Softbank if that makes a difference).

    Following the steps here:

    I tried numerous things:

    1. iOS 4.0 install + redsn0w 0.9.5b5-4 then backup of data = no mms/3g

    No MMS: there is no option for it at all anywhere. Not in the text message, picture itself or settings. No 3G: I can't load any web pages/data at all.

    Then I read somewhere that the -4 build of redsn0w is having problems so I try the previous -3 version:

    2. iOS 4.0 restore/install + redsn0w 0.9.5b5-3 then backup of data = still no mms/3g

    Elsewhere I read that the backup data is what is causing the trouble so I try:

    3. iOS 4.0 restore/install + redsn0w 0.9.5b5-4 NO backup of data = still no mms/3g

    I also tried unlocking it with UltraSn0w, resetting all settings

    Next I restore it again but play around with it before doing redsn0w. Bone stock iOS 4.0 mms/3g works fine. Without redsn0w I load my backup data back onto it and 3G/mms both still work fine in iOS 4.0. So the problem is definitely happening with the redsn0w JB.

    At this point I'm going to have to give up on JB'ing my device until a more stable build comes about I guess.

    Anyone else have problems? Or have a solution?
  2. Ultrakla$$ic macrumors member

    Jun 24, 2010
    Edge of Insanity!
    I'm sorry I don't have any answers for you but if you would allow me to ask a question.............or two.

    When you guys that have no MMS, are you saying you can't text or send messages or both? I ask because I've jailbroken my Iphone 3G and everything works. I can text, send pics in a message, and everthing I used to do.

    Am I missing something? Please excuse my ignorance, as I'm trying to familarize myself with all the jargon and look for possible issues with my phone if I can find them.
  3. bigsexyy81 macrumors 6502a


    May 2, 2010
    Same setup as you: 8 GB 3G with iOS 4 and jb redsn0w

    I can text message people fine, but have no option to send MMS. Not in the messages (no Camera icon to pick an image), while viewing a photo I do not have the option to send via MMS. I disabled EDGE and tried loading web page or apps and said I was not connected to internet even though I have full bars and a G next to them.

    WTF? I wish things would just work the way they are supposed to.
  4. trumptman macrumors newbie


    Jun 25, 2010
    I had this happen when I had gone into Cydia and installed the Tmobile carrier package for MMS/Internet/Etc. When I removed it the settings and options came back.
  5. dunk321 macrumors newbie

    Aug 24, 2007
    I upgraded iPhone 3G to 4.O, followed by Jailbreaking using Redsnow. MMS was no longer available. After a fresh apple restore with no back up it was there. After many installs and restores I pinned it to installing Cydia. By doing a fresh install, followed by a jailbreak ONLY, enabling multitasking and wallpapers, I now have MMS and everything is working good. Whoever said 4.0 is slow on the 3g must be trying to run 20 apps, it seems faster then the older firmware with multitasking and wallpaper enabled. Its sucks not having Cydia installed, but at least the new features are there.
  6. Imsuperjp macrumors 6502

    Apr 9, 2010
    What's the point of jail breaking and not having cydia installed? everything works fine for me
  7. antrikikin macrumors newbie

    Aug 3, 2009
    Merritt Island, FL
    Cellular/Data/MMS settings

    I've been JB for about a year on 3G. I upgraded this week and everything's back to working the same for me. However, I have never been able to just text. I can MMS w/pic but never just pic. What settings are you all using for t-mobile? Maybe it's because of the data plan I have.
  8. Imsuperjp macrumors 6502

    Apr 9, 2010
    - Install clean copy of OS4
    - Jailbreak w/redsn0w 0.9.5b5-3
    - Jailbreak w/redsn0w 0.9.5b5-4 (But deselect Cydia)

    Should fix the problem
  9. djasterix macrumors 6502a


    Apr 10, 2010
    Paradise City
    I just JB my 3G iphone a few minutes ago, redsnOw 0.9.5b5-4 without Cydia and multitaskn]ing, everything is working ok, including 3G, SMS and MMS
  10. str0ppy macrumors member

    Jun 27, 2010
    Exactly the same thing happened to me after jailbreaking with redsn0w 0.9.5b5-4. Was able to enable data again but no MMS (not that fussed).

    Probably going to wait for the final release then restore and JB again.
  11. bigsexyy81 macrumors 6502a


    May 2, 2010
    Curious if this would actually do the trick. Anyone confirm? This would take me two to three hours to get it back to stock 4.0 if it didn't work so I don't want to try if someone says it doesn't work.
  12. Imsuperjp macrumors 6502

    Apr 9, 2010
  13. tjlmbklr macrumors member

    Jun 29, 2010
    Sorry to thread hijack here but just JB yesterday to 4.0 using redsn0w and I too have no mms option. If I try to JB again and unchecked Cydia then what's the point of a JB?

    Anyone have the solution here?
  14. Aries326 macrumors 6502

    Dec 28, 2007
    I just jail broke my wife's iPhone 3G and I used PwnageTool - the latest version.

    This is what I did:

    Phone was originally jailbroken with 3.0. I went into DFU mode and had the latest 4.0 software installed via iTunes.

    I downloaded the latest PwnageTool

    I downloaded the proper ipsw file from here:

    I then used Pwnage to make the custom ipsw file.

    I then used iTunes to restore the phone, holding down the option key and choosing the custom ipsw file.

    Now with the jailbroken phone, I went and installed the Ultrasnow package through Cydia. Unlock complete.

    I then searched for the install file to install the proper settings for T-Mobile. Still, not all the settings were right. I then found a website that suggest I change in the cellular data portion to

    My wife's iPhone 3G now has iOS 4.0 and it completely works with T-Mobile. MMS, maps, EDGE, etc. 4.0 is VERY slow on the 3G. I'm planning on jailbreaking my 3GS, giving it to her and getting the iPhone 4.0 as soon as the white model comes out.
  15. Wubby thread starter macrumors newbie

    Jun 21, 2010
  16. eastercat macrumors 68040


    Mar 3, 2008
  17. iMrNiceGuy0023 macrumors 68000

    Jun 5, 2009
  18. Wubby thread starter macrumors newbie

    Jun 21, 2010
    I didn't reinstall 4.0 before trying the new version. But then again I was on a non Jailbroken 4.0 before using the latest Redsn0w.
  19. angemon89 macrumors 68000


    Feb 5, 2008
    The place where Apple designs stuff
    On a 3G: I would restore back to stock 4.0 and then use the new version of redsn0w to jailbreak.
  20. itsricky macrumors newbie

    Jul 14, 2010

    Hey Kids
    I just used the new redsn0w 0.9.5-5 - and it worked well on my 8GB 3G.

    Previously, i had used the -4 beta, and the cellular data tab was there but no data was coming through. Now, this is fixed, and the internet over 3g on Vodafone in australia is coming through very fast!

    Previously i had upgraded using the apple itunes method, and then jailbroken, but it was so slow it was ridiculous. I had planned to downgrade to 3.1.2 but because there were no reliable methods out there, I decided to give 4.0 a last change with a fresh install. So far so good - there is no memory lag and the phone is performing very well.

    So the new redsn0w 0.9.5-5 works well, visual voicemail is working now too - which wasn't working before!

    Oh - it gave me an error about the springboard crashing as soon as i re-booted, but I just restarted the phone once it had finished initializing, and it was fine after that.

    Thanks for everyone posting - this is what makes it easy for us n00bz!

    Update: I just ran the redsn0w app on the already JB iphone (with 'install cydia' UNCHECKED) - no need for a restore to stock ios4.0.

Share This Page